Áàçîâûå îïðåäåëåíèÿ è ñâåäåíèÿ

Базовые определения и сведения

 Начало Следующий

Настоящее пособие является Руководством по Интерфейсу системы Universal Accounting.

Universal Accounting – универсальная ERP-система бухгалтерского учета и финансово-экономического анализа.

Система функционирует в операционных средах семейства Windows. Используются графические возможности и средства Windows (работа с окнами, буфером обмена и пр.). Исходя из этого, следующие знания и навыки (помимо узко-профессиональных) являются желательными для пользователей системы:

- Работа с Windows – общие принципы функционирования, работа с окнами, использование мыши, буфер обмена и пр.

- Работа с Excel – работа с таблицами, данными, формулы.

- Работа с Word – работа с текстом, форматирование.

- Учебное Руководство пользователя по Universal Accounting – учебное пособие, помимо интерфейса, описывающее базовые принципы работы системы и логическую организацию (настройка системы, счетов, аналитических справочников, дополнительные бухгалтерские рекомендации и информация).

Система относится к классу многопользовательских систем и обеспечивает одновременную работу произвольного количества пользователей, независимо от выполняемых действий (ввод данных, формирование отчетов) и учетного сектора.

© 2007 Eugen Colesnicov, version 1.0.1


Ñîñòàâ ñèñòåìû Universal Accounting

Состав системы Universal Accounting

 Начало Предыдущий Следующий

Работу с системой Universal Accounting условно можно разделить на несколько частей:

- Работа с документами

- Работа со справочниками и формами

- Работа с отчетами

Система является документно-ориентированной, именно с помощью Документов выполняются все действия по поддержанию адекватного отображения финансово-экономической и хозяйственной деятельности предприятия в базе данных системы. Документы в системе соответствуют первичным бумажным документам.

Через Справочники задаются условно-постоянные перечни объектов учета, операции над которыми реализуются через документы (подразделения, работники, товары, материалы и пр.).

Формы – некая статическая информация, обновляемая с определенной периодичностью (курсы валют, нормы расхода материалов, рабочего времени, кадровая информация о сотрудниках и т.д.), также существующая для просмотра и внесения в документы.

Отчетами являются экранные и печатные формы (не привязанные к документам) отображающие определенную информацию суммарно по выбранным документам, проводкам и объектам аналитического учета за указанный период.


Çàïóñê ñèñòåìû è ðåãèñòðàöèÿ ïîëüçîâàòåëÿ

Запуск системы и регистрация пользователя

Первичный запуск системы Universal Accounting осуществляется через иконку на рабочем столе:

Для идентификации пользователя используется Окно Регистрации:

- Поле Сервер – настраивается администратором и запоминается в выпадающем списке. Для выбора из списка нажмите стрелку вниз у правой границы поля.

- Поле Имя – Ваше имя пользователя, установленное администратором.

- Поле Пароль – Ваш секретный пароль, для подтверждения имени.

- Кнопка OK – Нажмите эту кнопку для начала загрузки основного приложения системы, после заполнения вышеуказанных полей (можно использовать клавишу Enter на клавиатуре).

- Кнопка Отмена – Для закрытия окна регистрации, без запуска системы, т.е. выход из системы (можно использовать Esc).

- Кнопка Детали – предназначена для администратора системы.


Çàâåðøåíèå ðàáîòû ñ ñèñòåìîé

Завершение работы с системой

Завершение работы с системой Universal Accounting возможно следующими способами:

- Через пункт главного меню «Выход».

- Через кнопку закрытия окна системы «крестик» [image] , расположенную в верхнем правом углу главного окна системы (для всех Windows-приложений).

- Через горячую клавишу Alt+F4.

При завершении работы с системой выдается предупредительное сообщение:

В зависимости от содержимого и режимов дочерних окон, могут выдаваться другие дополнительные сообщения, предупреждения и вопросы.


Ãëàâíîå ìåíþ ñèñòåìû – îáùåå îïèñàíèå

Главное меню системы – общее описание

В верхней части окна системы Universal Accounting расположено Главное Меню системы:

Пункты меню представляют собой выпадающие, при нажатии мышки (или Alt-горячей клавишей), списки с собственным меню или просто исполняющую кнопку. Также доступ к меню возможен через горячую клавишу F10.

Пункты главного меню:

- Журналы – это совокупность созданных документов (операций), принадлежащих одному программному модулю (или участку учета). Данный пункт меню предоставляет доступ к данным журналам (доступ к отдельным журналам может быть ограничен, исходя из прав пользователя). Подробнее смотрите Журналы документов и меню Журналы главного меню.

-

Документ содержит перечень операций, доступных для выполнения над выбранным из журнала документом. Подробнее смотрите Меню Документ Главного меню.

- Справочники предоставляет доступ к справочникам системы Universal Accounting. Подробнее смотрите Справочники системы и меню Справочники главного меню.

- Отчеты предоставляет доступ к разнообразным отчетам системы Universal Accounting. Подробнее смотрите Отчеты системы и меню Отчеты главного меню.

- Формы предоставляет доступ к формам системы Universal Accounting. Подробнее смотрите Формы системы и меню Формы главного меню.

- Сервис обеспечивает некоторые сервисные функции системы Universal Accounting. Данный пункт меню предназначен для администраторов системы и в рамках настоящего Руководства рассмотрен не будет.

- Окна обеспечивает работу с дочерними окнами, в рамках основного окна системы. Подробнее смотрите Меню Окна Главного меню.

- Помощь предоставляет доступ к справочной системе Universal Accounting. Подробнее смотрите Меню Помощь Главного меню.

- Выход позволяет пользователю завершить работу с системой Universal Accounting. Дополнительно смотрите Завершение работы с системой.

Помимо пунктов меню, на панели Главного меню располагаются инструменты интерактивной справочной системы Universal Accounting: , [image] . Этими инструментами обеспечивается контекстное открытие соответствующих разделов руководства пользователя по горячей клавише или щелчку мыши по любому графическому объекту системы. Подробнее смотрите Меню Помощь Главного меню.

Также, при нажатии правой кнопки мыши на главном меню появляется т.н. Контекстное Меню (пункты данного меню зависят от положения мыши при нажатии правой кнопки мыши), которое позволяет настроить внешний вид и параметры отображения главного меню и панелей инструментов системы. Подробнее смотрите Контекстное меню главного меню системы.


Ìåíþ Îêíà Ãëàâíîãî ìåíþ

Меню Окна Главного меню

Система Universal Accounting использует многодокументный интерфейс, т.е. внутри главного окна системы возможно одновременное наличие многих дочерних окон. Меню Окна обеспечивает работу с этими дочерними окнами:

Пункты меню Окна:

- Расположить, подпункт Черепица – располагает дочерние окна системы, в рамках основного окна, так чтобы одновременно были видны все они.

- Расположить, подпункт Каскад – располагает дочерние окна системы так, чтобы были видны их заголовки.

- Расположить, подпункт Закрыть все – закрывает все открытые дочерние окна системы (в зависимости от содержимого и режимов дочерних окон могут выдаваться дополнительные предупреждения).

- Далее, по номерам, в качестве пунктов меню, перечислены все открытые дочерние окна в системе. Напротив активного дочернего окна указана «галочка»: . Соответственно пользователь, выбрав тот или иной пункт, может переключаться (сделать активным) на то или иное дочернее окно.

Для циклического переключения окон используйте горячую клавишу Ctrl+Tab или Ctrl+F6.

Также переключение окон доступно через панель инструментов «Список окон» (если включен режим отображения для данной панели). Подробнее смотрите Контекстное меню главного меню системы.

Все остальные базовые функции (закрытие окна, сворачивание/разворачивание, на весь экран/главное окно, изменение размеров), по работе с дочерними окнами, аналогичны стандартным функциям по работе с окнами в операционных системах Windows. Для подробного изучения обратитесь к справочному материалу по Windows.

Дополнительно смотрите Главное меню системы – общее описание.


Ìåíþ Ïîìîùü Ãëàâíîãî ìåíþ

Меню Помощь Главного меню

Система Universal Accounting обладает развитой двухуровневой справочной системой:

- Общее руководство пользователя – настоящее руководство, описывающее базовые принципы организации системы и подробное описание всех общих графических элементов системы любых уровней (интерфейс системы) и общих принципов работы с ними. Данное руководство поставляется вместе с программой и едино для всех конфигураций системы на всех предприятиях.

- Руководство по конфигурации – характеристика и логические принципы работы с конкретными документами, справочниками, формами, отчетами. В связи с наличием большого многообразия конфигураций программы (типовых и специализированных), составляется индивидуально для каждой конкретной конфигурации. Поставляется в рамках внедрения и развития базы данных и определяется и настраивается администратором системы (в связи с чем может быть недоступно в некоторых случаях).

Данный двухуровневый принцип построения обеспечивает полноту информационного охвата и в тоже время удобное разделение, исходя из принципа: общее / частное.

Доступ к Справочной подсистеме Universal Accounting обеспечивается посредством Меню Помощь Главного меню либо через иконки на панели Главного меню, а также горячие клавиши (для отдельных пунктов):

Состав меню Справка:

- Общая справка – предоставляет доступ к общему руководству пользователя по интерфейсу (настоящему руководству).

- Справка по предприятию – предоставляет доступ к руководству пользователя по внедрению (может быть недоступно).

- [image] Справка ? (Shift+F1) – контекстная справка по элементам интерфейса. При выборе этого пункта меню, курсор мыши меняет свои вид: к обычной стрелке добавляется знак вопроса. После этого, при щелчке мыши по любому графическому объекту на экране (в рамках системы) будет показано именно его справочное описание (из общего руководства пользователя по интерфейсу).

- [image] Текущая справка (F1) – контекстная справка по документам, справочникам, формам, отчетам. В зависимости от текущего активного документа, формы, справочника, отчета будет показано именно его описание (из руководства по внедрению).

- Об этой программе (Alt+F1) – Диалоговое окно краткого описания программы.

Внешний вид окна «Об этой программе»:

Дополнительно смотрите Главное меню системы – общее описание.


Êîíòåêñòíîå ìåíþ ãëàâíîãî ìåíþ ñèñòåìû

Контекстное меню главного меню системы

Контекстное меню, показываемое при нажатии правой кнопкой мыши на главном меню, позволяет настроить внешний вид и параметры отображения главного меню и панелей инструментов системы (текущие активные настройки отображаются [image] – «галочками», слева от названий):

Пункты контекстного меню:

- Панели Инструментов, подпункт Главное меню – отображение на экране главного меню системы (отображается всегда).

- Панели Инструментов, подпункт Дополнит. – отображение на экране основной панели инструментов, ниже главноо меню (отображается всегда). Подробнее смотрите Основная панель инструментов.

- Панели Инструментов, подпункт Период – отображение на экране панели инструментов «Период», показывающей период, в рамках которого возможно редактирование (определяется через приложение «Администратор системы»), период для показа в журналах документов и точку актуальности (текущую дату). Данная панель в случае отображения будет расположена ниже Основной панели инструментов. Подробнее смотрите Панель инструментов Период.

- Панели Инструментов, подпункт Форма – отображение на экране панели инструментов для форм. Является контекстной, по отношению к формам (показывается только при выборе форм). Также контекстно показываются те или иные кнопки на ней. Эта панель предоставляет дополнительные действия и операции для форм.

- Панели Инструментов, подпункт Список окон – панель инструментов, показывающая список всех имеющихся дочерних окон системы и позволяющая оперативно переключать их. Также переключение дочерних окон возможно через пункт главного меню «Окна» или с помощью горячей клавиши Ctrl+Tab или Ctrl+F6.

- Крупные значки, Средние значки, Мелкие значки взаимоисключающе определяют величину значков пунктов главного меню (при выборе режимов отображения значков).

- Значок над текстом, Значок и текст, Только значок и Только текст позволяют выбрать варианты совместного отображения значков и текстов пунктов главного меню.


Îñíîâíàÿ ïàíåëü èíñòðóìåíòîâ

Основная панель инструментов

Под главным меню расположена Основная Панель Инструментов:

Данная панель инструментов предоставляет пользователю, в основном, универсальные функции по работе с записями в таблицах. Основная часть инструментов ( [image] ) является универсальным Навигатором экранных таблиц. Подробнее смотрите Навигатор экранных таблиц.

Перечень других инструментов:

- [image] Расширенный фильтр – через специальное диалоговое окно позволяет осуществлять расширенную фильтрацию записей журналов документов. Подробнее смотрите Расширенная фильтрация записей журнала документов.

- [image] Выбор языка – через выпадающее меню позволяет переключать язык интерфейса системы. Для выбора доступно 3 варианта: русский, румынский, английский.

- [image] – предназначены для администраторов системы.

- [image] – имя текущей базы данных Oracle.

Текстовые подсказки для значков на панелях инструментов будут выведены при наведении мыши на значок. В зависимости от контекста часть значков (инструментов) может быть недоступна пользователю (неактивна).


Ïàíåëü èíñòðóìåíòîâ Ïåðèîä

Панель инструментов Период

Ниже основной панели инструментов располагается панель инструментов «Период»:

Режим ее отображения настраивается через контекстное меню главного меню системы. Подробнее смотрите Контекстное меню главного меню системы.

На данной панели располагаются следующие инструменты:

- Просмотр – период для показа в журналах документов. Позволяет ускорить работу за счет исключения из журнала записей ниже или выше указанных дат. Подробнее смотрите ниже.

- Правка – период, доступный для редактирования. Определяется администратором. Пользователям изменение этого периода недоступно.

- Сегодня – точка актуальности (текущая дата).

Инструмент Просмотр показывает период для показа в журналах документов. Незаполненные поля означают отсутствие ограничений. Возможно несколько комбинаций:

- Ограничение снизу (не показывать записи журналов ниже заданной даты).

- Ограничение сверху (не показывать записи журналов выше заданной даты).

- Двойное ограничение (ограничивать показ только указанным периодом).

Настройка данных ограничений производится в специальном диалоговом окне по нажатию кнопки [image] , справа от полей на панели, показывающих период:

Перечень элементов:

- Дата начала – поле выбора начальной даты (ограничение снизу), показываемое при проставленной «галочке» на дате начала.

- Дата конца – поле выбора конечной даты (ограничение сверху), показываемое при проставленной «галочке» на дате начала.

- Кнопка OK – Закрывает окно с применением сделанных установок.

- Кнопка Отмена – Закрывает окно без сохранения установок.


Ðàáîòà ñ ýêðàííûìè òàáëèöàìè

Работа с экранными таблицами

В системе Universal Accounting все экранные таблицы представляют собой стандартизированные объекты с единым принципом построения и использования. Имеют похожий интерфейс, функциональные возможности и горячие клавиши. Это касается таблиц журналов документов, таблиц в документах, справочниках, формах, отчетах. Таблицы отличаются только логическим наполнением, а также, возможно. количеством и составом колонок, цветом полей. Соответственно, для работы с любыми экранными таблицами в системе используются единые приемы и механизмы.

Далее будут приведены примеры экранных таблиц в системе (таблица журнала документов, табличная часть документа, таблица справочника счетов, таблица аналитических справочников):

Особенности работы и использования различных экранных таблиц приведены в соответствующих разделах настоящего руководства.

Работа пользователя с экранными таблицами производится посредством:

- Манипулятора мышь

- Клавиатуры

При использовании мыши задействуются стандартные возможности Windows-программ: перемещение по видимой части экрана, прокрутка колесиком мыши, активация кликом, полосы прокрутки и пр.

Доступ к режимам, сервисным операциям и прочим возможностям возможен посредством: горячих клавиш (описаны ниже), контекстного меню, навигатора экранных таблиц. Подробнее смотрите Контекстное меню экранных таблиц, Навигатор экранных таблиц.

Клавиатура используется для:

- Операций перемещения по таблице.

- Переключения визуальных режимов, режимов состояния и выполнения действий.

- Выполнения сервисных операций.

Также более подробно будет рассмотрена работа с таблицами в режиме редактирования.

Перемещение:

- ^v (стрелки вверх и вниз) – перемещение на одну строку вверх/вниз.

- <> (стрелки влево и вправо) – перемещение на один столбец влево/вправо. Доступно только в режиме, где возможна активация отдельных полей (переключается по F2).

- PageUp, PageDown – перемещение на одну страницу вверх/вниз.

- Home (Ctrl+<), End (Ctrl+>) – переход на первый/последний столбец в активной строке для режима, где возможна активация отдельных полей, переход на первую/последнюю строку в таблице для режима выделения всей строки (переключается по F2).

- Ctrl+Home (Ctrl+F11), Ctrl+End (Ctrl+F12) – переход на первую/последнюю запись в таблице.

- Ctrl+^, Ctrl+v – переход на первую/последнюю видимую запись в экранной таблице.

- Tab – последовательное перемещение по полям таблицы (слева направо, далее на следующую строку вниз и т.д.)

- Shift+Tab – последовательное перемещение по полям таблицы в обратном порядке (справа налево, далее на предыдущую строку вверх и т.д.)

Режимы и действия:

- F2 – переключение режима выделения всей строки / отдельного поля

- F7 – сортировка по активному столбцу (для режима выделения отдельных полей). Двойное выполнение для одного и того же столбца изменяет порядок сортировки: прямой и обратный.

- Ins – добавление новой записи в конец таблицы (для таблиц журналов также можно использовать Ctrl+Minus.

- Ctrl+Plus – дублирование текущей записи журнала документов. Дублируется запись в журнале документов и сам документ (его экранная форма). Проводки не дублируются.

- Shift+Ins – вставка новой записи ниже текущей.

- F4, Enter (Esc), – переключение режима просмотра и режима редактирования для активной строки таблицы. Более подробно особенности работы в данном режиме будут рассмотрены ниже.

- Ctrl+` – сразу осуществляет переход на таблицу содержимого документа, если текущая запись – документ в таблице журнала документов или выход с сохранением из документа, если текущая запись – строка таблицы содержимого документа. Действует только для таблиц журналов документов.

- Ctrl+Del – удаление активной строки таблицы. Для некоторых экранных таблиц могут быть наложены дополнительные ограничения (например, на удаление записей из таблиц журналов документов).

- F5 – обновление настроек.

Сервисные операции:

- Ctrl+Z – запускает диалоговое окно, обеспечивающее возможность поиска по любому из имеющихся полей таблицы. Также данная функция вызывается через иконку [image] на Навигаторе экранных таблиц. Подробнее смотрите Поиск записей экранных таблиц. В дополнение, возможен быстрый поиск путем набора искомого содержимого в соответствующем поле любой таблицы.

- Ctrl+N – поиск следующей записи при определенном критерии поиска.

- Ctrl+F – запускает диалоговое окно, обеспечивающее фильтрацию таблицы по любому из имеющихся полей. Также данная функция вызывается через иконку [image] на Навигаторе экранных таблиц. Подробнее смотрите Фильтрация записей экранных таблиц.

- Ctrl+Shift+F – фильтрация по текущему активному полю. Все строки таблицы с аналогичным содержимым данного поля будут выведены на экран.

- Alt+F – снятие всех установленных фильтров.

- Alt+R – обновление экранной таблицы.

- Ctrl+Q – запускает диалоговое окно для ввода значения по умолчанию (дата, тип операции, и пр.) Введенное значение будет появляться автоматически при добавлении следующих записей.

- Ctrl+Shift+Q – установка значения по умолчанию на основе текущей записи.

- Ctrl+Alt+Q – сброс установленного значения по умолчанию.

- Ctrl+D – копировать значение из предыдущей записи в активное поле.

Режим редактирования, подробнее:

- F4, Enter (Esc) – включение / выключение режима редактирования.

- Ctrl+` – сразу осуществляет переход на таблицу содержимого документа, если текущая запись – документ в таблице журнала документов или выход с сохранением из документа, если текущая запись – строка таблицы содержимого документа. Действует только для таблиц журналов документов.

- Применяются следующие графические идентификаторы (в начале активной записи): режим просмотра – [image] , режим редактирования – [image] .

- В режиме редактирования (ввода) перемещение по таблице аналогично перемещению в режиме просмотра.

- Ввод или редактирование конкретных полей зависят от типа поля.

- Для текстовых или цифровых полей – это простой ввод, с использованием всех стандартных, для операционных систем Windows, возможностей: выделение, использование буфера обмена, перемещение внутри поля и пр. (комбинации клавиш также стандартны).

- Для поля с выпадающим списком используются: Alt+v (стрелка вниз) – вывод на экран выпадающего списка (при этом выпадающий список также может представлять собой экранную таблицу); Del – удаление значения; Esc – отмена изменений.

- В некоторых случаях (например, при первоначальном заполнении), выпадающий список выводится на экран при переходе в поле с выпадающим списком (без необходимости использования комбинации клавиш).


Êîíòåêñòíîå ìåíþ ýêðàííûõ òàáëèö

Контекстное меню экранных таблиц

Контекстное меню экранных таблиц

Контекстное меню, показываемое при нажатии правой кнопкой мыши на экранной таблице, действует для всех таблиц в рамках системы Universal Accounting (также применимо к табличным частям документов, справочников, форм, отчетов):

Пункты контекстного меню:

- Search (Ctrl+Z) – запускает диалоговое окно, обеспечивающее возможность поиска по любому из имеющихся полей таблицы. Также данная функция вызывается через иконку [image] на Навигаторе экранных таблиц. Подробнее смотрите Поиск записей экранных таблиц. В дополнение, возможен быстрый поиск путем набора искомого содержимого в соответствующем поле любой таблицы.

- Search Next (Ctrl+N) – поиск следующей записи при определенном критерии поиска.

- Filter (Ctrl+F) – запускает диалоговое окно, обеспечивающее фильтрацию таблицы по любому из имеющихся полей. Также данная функция вызывается через иконку [image] на Навигаторе экранных таблиц. Подробнее смотрите Фильтрация записей экранных таблиц.

- Filter on current value (Ctrl+Shift+F) – фильтрация по текущему активному полю. Все строки таблицы с аналогичным содержимым данного поля будут выведены на экран.

- Free Filter (Alt+F) – снятие всех установленных фильтров.

- Refresh (Alt+R) – обновление экранной таблицы.

- Default Value (Ctrl+Q) – запускает диалоговое окно для ввода значения по умолчанию (дата, тип операции, и пр.) Введенное значение будет появляться автоматически при добавлении следующих записей.

- Self Default Value (Ctrl+Shift+Q) – установка значения по умолчанию на основе значения поля текущей записи.

- Free Def Value (Ctrl+Alt+Q) – сброс установленных значений по умолчанию.

- Copy Prev (Ctrl+D) – копировать значение поля предыдущей записи экранной таблицы после добавления новой записи или ее редактирования.

- Export to Excel (Grid) – экспорт в Excel экранной таблицы.

- Export to Excel (Table) – экспорт в Excel из базы данных всей таблицы, на основе которой построена экранная таблица.

- Save Grid Properties – сохранение настроек экранной таблицы. Применяется администраторами системы.

- Advanced Properties – доступ к подменю настройки дополнительных свойств. Применяется администраторами системы.

- Insert from clipboard – Вставка из буфера обмена. Обеспечивает возможность импорта данных из буфера обмена в таблицу. Таким образом, можно подготовить данные в Excel и потом просто перенести их в систему посредством буфера обмена. Для правильного выполнения импорта формат данных в буфере обмена должен совпадать с форматом таблицы, в противном случае будет выведено сообщение об ошибке.

Как видно, большинство данных функций доступно также посредством горячих клавиш. Подробнее смотрите Работа с экранными таблицами.


Íàâèãàòîð ýêðàííûõ òàáëèö

Навигатор экранных таблиц

Для наглядности и удобства работы с любыми экранными таблицами в системе используется табличный Навигатор экранных таблиц: Навигатор может встраиваться в другие панели инструментов (Основная панель инструментов, Панель инструментов аналитических справочников) или использоваться самостоятельно (в системных справочниках).

Внешний вид навигатора экранных таблиц:

Навигатор предоставляет пользователю универсальные функции по работе с записями в таблицах. Существует множество мест применения в рамках системы: записи журналов документов, записи табличной части документов, поля выбора из справочников и форм и пр. В случае, если на экране видны сразу несколько из вышеперечисленных элементов, то текущий элемент определяется исходя из того, какой из них является активным, т.е. имеет фокус. Также надо иметь в виду, что исходя из конкретного смысла, некоторые из управляющих значков (или даже все) могут быть недоступны.

Инструменты навигатора:

- [image] Первая запись – переход на первую (начальную) запись в таблице.

- [image] Предыдущая запись – переход на предыдущую (от текущей) запись в таблице.

- [image] Следующая запись – переход на следующую (от текущей) запись в таблице.

- [image] Последняя запись – переход на последнюю запись в таблице.

- [image] Вставка записи – добавление записи в таблицу. Будет выведено контекстное окно, с перечнем доступных для добавления типов документов в активном журнале.

- [image] Удаление записи – удаление записи из таблицы. Данное действие может быть ограничено исходя из прав пользователя.

- [image] Редактирование записи – позволяет включать режим редактирования записи.

- [image] Сохранение редактирования – Сохраняет сделанные изменения при завершении режима редактирования.

- [image] Отмена редактирования – отменяет режим редактирования (сделанные изменения не сохраняются).

- [image] Обновление списка – обычно обновление осуществляется по мере редактирования, но при возможной совместной работе или других случаях данный управляющих значок позволяет обновить таблицу на экране из базы данных.

- [image] Фильтр – запускает диалоговое окно, предоставляющее средства для фильтрации таблицы по любому из имеющихся полей. Также данная функция вызывается по горячей клавише Ctrl+F. Подробнее смотрите Фильтрация записей экранных таблиц.

- [image] Поиск – запускает диалоговое окно, предоставляющее средства для поиска по любому из имеющихся полей. Данная функция вызывается по горячей клавише Ctrl+Z. Подробнее смотрите Поиск записей экранных таблиц. Также возможен быстрый поиск путем набора искомого содержимого в соответствующем поле любой таблицы.


Ôèëüòðàöèÿ çàïèñåé ýêðàííûõ òàáëèö

Фильтрация записей экранных таблиц

Установка условий (настройка) фильтрации записей экранных таблиц осуществляется через специальное диалоговое окно Фильтр.

Окно предназначено для фильтрации (отбора) записей в любых экранных таблицах в рамках системы Universal Accounting, по выбранному полю (колонке) или нескольким полям. Также возможна установка дополнительных условий (параметров сравнения).

Вызов окна Фильтр возможен посредством горячей клавиши Ctrl+F, через контекстное меню экранных таблиц, через инструмент [image] навигатора экранных таблиц.

Имеется два режима работы, переключение которых осуществляется по нажатию кнопки Расширенный фильтр:

- Обычный – возможна фильтрация только по одному полю

- Расширенный – допускается фильтрация по нескольким полям. В этом режиме диалоговое окно расширяется.

Внешний вид окна в обычном режиме:

Перечень элементов в обычном режиме:

- Поле – выпадающий список полей таблицы (причем в нем представлены даже поля, отсутствующие в экранном представлении таблицы). Необходимо выбрать определенное поле, для установки значения фильтра по нему.

- Значение – Устанавливаемое значение фильтра для выбранного поля таблицы.

- Текст. опции, Полное совпадение – параметр для текстовых полей, позволяющий фильтровать с условием полного совпадения искомого значения и поля таблицы.

- Текст. опции, Искать внутри строки – параметр для текстовых полей, позволяющий фильтровать с условием произвольного вхождения искомого значения в поле таблице.

- Текст. опции, Строка начинается с … – параметр для текстовых полей, позволяющий фильтровать с условием вхождения искомого значения начиная с начальных символов поля таблицы.

- Текст. опции, Нечеткое сравн. – позволяет выполнять нечеткое сравнение, также возможна установка дополнительного параметра – коэффициента похожести (0-10).

- Учитывать регистр – параметр, определяющий надо ли учитывать регистр букв при фильтрации.

- Lookup, Cod – фильтр по кодам.

- Lookup, Text – фильтр по тексту.

- Кнопка Расширенный фильтр – переключает стандартный и расширенный режим диалогового окна, добавляя несколько полей. Основное отличие – возможность установки фильтра сразу по нескольким полям.

- Кнопка OK – нажмите для непосредственной фильтрации, исходя из установленных параметров.

- Кнопка Cancel – отмена фильтрации (закрывает диалоговое окно).

Внешний вид окна в расширенном режиме:

Перечень дополнительных элементов, для расширенного режима:

- Поле Сгенерированное выражение – специальное поле расширенного режима, показывающее текстовое представление условий фильтра.

- Таблица Сгенерированное выражение – специальная таблица расширенного режима, показывающая таблицу с полным перечнем полей и все фильтры, установленные на полях таблицы.

- Кнопка Построить – специальная кнопка расширенного режима, добавляет условия фильтра к сгенерированному выражению (предыдущим условиям фильтра).

- Кнопка Очистить – специальная кнопка расширенного режима, очищает условия фильтра (очищает сгенерированное выражение).

Дополнительно смотрите Работа с экранными таблицами, Контекстное меню экранных таблиц, Навигатор экранных таблиц.


Ïîèñê çàïèñåé ýêðàííûõ òàáëèö

Поиск записей экранных таблиц

Установка условий (настройка) поиска записей экранных таблиц осуществляется через специальное диалоговое окно Поиск.

Окно предназначено для поиска записей в любых экранных таблицах в рамках системы Universal Accounting, по выбранному полю (колонке). Также возможна установка дополнительных условий (параметров сравнения).

Вызов окна Поиск возможен посредством горячей клавиши Ctrl+Z, через контекстное меню экранных таблиц, через инструмент [image] навигатора экранных таблиц.

Внешний вид:

Перечень элементов:

- Field – выпадающий список полей таблицы (причем в нем представлены даже поля, отсутствующие в экранном представлении таблицы). Необходимо выбрать определенное поле, для поиска по нему.

- Value – Значение для поиска по выбранному полю таблицы.

- Exact match – параметр для текстовых полей, позволяющий выполнять поиск с условием полного совпадения искомого значения и поля таблицы.

- @ and … – параметр для текстовых полей, определять множественный поиск.

- Advanced pattern match – параметр для текстовых полей, определяющий опцию расширенного поиска.

- Case-sensitive – параметр, определяющий надо ли учитывать регистр букв при поиске.

- Lookup, Cod – поиск по кодам.

- Lookup, Text – поиск по тексту.

- Кнопка OK – нажмите для непосредственного поиска, исходя из установленных параметров.

- Кнопка Cancel – отмена поиска (закрывает диалоговое окно).

Дополнительно смотрите

Работа с экранными таблицами

, Контекстное меню экранных таблиц, Навигатор экранных таблиц.


Æóðíàëû äîêóìåíòîâ è ìåíþ Æóðíàëû ãëàâíîãî ìåíþ

Журналы документов и меню Журналы главного меню

Журнал – это совокупность созданных документов (операций, проводок), принадлежащих одному программному модулю (или участку учета). В программе существует столько видов журналов, сколько модулей задействовано в данной конфигурации программы.

Меню Журналы предоставляет пользователям доступ к журналам документов. При этом доступ к отдельным журналам может быть ограничен исходя из прав пользователя:

Журнал документов используется для работы с документами (ввод нового документа, редактирование, проведение, просмотр проводок, и пр.). В каждом журнале документы отображаются в виде списка (таблицы) записей. По каждому документу отображается краткая информация (дата, наименование, номер и т.д.).

Журнал «Стандарт» предоставляет доступ ко всем документам всех журналов. Также данный пункт меню сбрасывает все установленные фильтры.

Остальной перечень журналов не является фиксированным и может отличаться в зависимости от потребностей предприятия. Обычно журналы соответствуют участкам хозяйственной деятельности и бухгалтерского учета.

Также могут существовать Поджурналы – более узкие наборы документов в рамках какого-либо журнала. При наведении курсора мыши на соответствующий журнал, имеющий стрелочку, справа появится подменю с перечнем поджурналов по данному журналу.

Текущий активный журнал обозначается «галочкой» [image] , слева от названия. В системе может быть только один активный журнал (и соответственно только одно дочернее окно Журнала Операций).

Для рассмотрения общего строения окна журнала смотрите Окно журнала документов.

Для изучения внешнего вида, перечня полей и возможностей использования таблицы журнала документов смотрите Таблица журнала документов.


Îêíî æóðíàëà äîêóìåíòîâ

Окно журнала документов

При выборе желаемого журнала из меню открывается окно журнала (при первоначальном запуске системы автоматически загружается журнал Стандарт или журнал по умолчанию, определенный для данного пользователя администратором системы). Внешний вид окна текущего журнала разбит на 2 основные части:

- Верхняя часть – собственно сам текущий журнал, представляющий собой список (таблицу) документов.

- Нижняя часть – содержание выбранной записи журнала, т.е. собственно сам первичный документ.

По умолчанию, окно разделяется примерно на половину, однако, подведя указатель мыши к разделительной линии, захватив ее нажатием левой кнопки мыши, можно уменьшать или увеличивать видимые области журнала или документа.

Нижняя часть окна (документ) имеет 4 закладки, каждая из которых содержит разную информацию по документу: проводки документа, экранную форму документа, дополнительную информацию по документу, OLE-объекты, присоединяемые к документу. Подробнее смотрите Общее описание документов.

Некоторые функции по работе с документами возможны через меню Документ Главного меню системы. Подробнее смотрите Меню Документ Главного меню.

Между верхней частью окна (журналом) и нижней частью (документом) присутствует специальная документная панель инструментов, иконки на которой предоставляют функции по работе с документами и специальные средства: печатные формы документов, итоги по документу, действия над документом, дополнительные данные для печатных форм. Подробнее смотрите Документная панель инструментов.

Таблица журнала документов представляет собой стандартизированный объект – экранная таблица, посредством которого в рамках системы представляются все табличные данные и информация. Исходя из этого, работа с журналом документов осуществляется с помощью Основной панели инструментов, горячих клавиш и контекстного меню. Подробнее смотрите Основная панель инструментов, Работа с экранными таблицами, Контекстное меню экранных таблиц, Навигатор экранных таблиц.

Настройка периода отображения (интервала дат) в журналах возможна через панель инструментов «Период». Подробнее смотрите Панель инструментов Период.


Òàáëèöà æóðíàëà äîêóìåíòîâ

Таблица журнала документов

Журнал документов в системе Universal Accounting представляет собой таблицу с набором полей (колонок), каждая запись (строка) которой представляет первичный документ:

В таблице представлены следующие поля, идентифицирующие документ и предоставляющие дополнительную информацию по нему:

- Cod – уникальный код (идентификатор) данного конкретного документа, автоматически присваиваемый системой.

- Tipul operatiei – Тип документа / тип операции, описывающий смысл данного документа.

- Nr. Documentului – номер документа, присвоенный пользователем.

- Data – дата документа.

- USERID – уникальный код (идентификатор) пользователя.

- AT3 – показывает состояние проводок по документу (0 – проводки есть, но неактивны, 1 – проводки активны, пусто – проводки отсутствуют).

- SYSFID – уникальный код (идентификатор) типа документа / типа операции

- User_T – имя пользователя, создавшего / изменившего данный документ

В зависимости от настроек конкретного предприятия, некоторые из полей (колонок) могут отсутствовать и наоборот, присутствовать другие поля (колонки). Также могут отличаться названия полей (колонок) и их порядок. Даже в рамках одного предприятия данные настройки могут быть индивидуальны для каждого из журналов.

Текущее состояние документа (верен, неверен) помечается иконкой в начале строки:

- [image] Неверен – показывает неверное состояние документа. Включается автоматически при сохранении документа без проведения или перепроведения проводок либо при переходе в режим неактивного документа.

- [image] Верен – показывает верное состояние документа. Это означает, что документ активен и проводки по нему сформированы правильно.

- [image] Неопределенно – состояние документа неопределенно, возможно для случаев автоматического импорта данных в базу данных или ее прямого редактирования и заполнения.

В нормальном режиме строки таблицы имеют светло-желтый цвет (настройки цветов могут отличаться в зависимости от конфигурации или отсутствовать полностью):

Для текущей строки (т.е. для активного документа, показываемого в нижней части окна журнала) выбранное поле выделяется темно-синим цветом и вся строчка оттеняется (для режима выделения полной строки темно-синим выделяется вся строка):

Отсутствие проводок по документу представляется серым цветом строки таблицы журнала (настройки цветов могут отличаться в зависимости от конфигурации или отсутствовать полностью):

Удаление проводок по документу возможно через Документную панель инструментов. Дополнительно смотрите Документная панель инструментов.

Неактивный документ – документ, проводки которого не видны для отчетов, обозначается светло-голубым цветом строки таблицы журнала (настройки цветов могут отличаться в зависимости от конфигурации или отсутствовать полностью):

Сторно документ – это документ, дублированный с выбором свойств сторнирования: полного или разницы.

Документ окрашивается в зелёный, если на его вкладке [image] заполнено поле Сторно документ и в нём выполнено действие бухгалтерских проводок.

Возможность сделать документ активным или неактивным доступна через документную панель инструментов. Подробнее смотрите Документная панель инструментов.

Таблица журнала документов представляет собой стандартизированный объект – экранная таблица, посредством которого, в рамках системы, представляются все табличные данные и информация. Исходя из этого, использование журнала документов возможно посредством Основной панели инструментов, горячих клавиш и контекстного меню. Подробнее смотрите Основная панель инструментов, Работа с экранными таблицами, Контекстное меню экранных таблиц, Навигатор экранных таблиц.

Также, только для таблиц журналов документов доступна расширенная фильтрация документов (помимо стандартных возможностей по фильтрации, предоставляемых посредством навигатора экранных таблиц). Подробнее смотрите Расширенная фильтрация журнала документов.


Ðàñøèðåííàÿ ôèëüòðàöèÿ æóðíàëà äîêóìåíòîâ

Расширенная фильтрация журнала документов

Таблица журнала документов представляет собой стандартизированный объект – экранная таблица, посредством которого, в рамках системы, представляются все табличные данные и информация. Исходя из этого, использование журнала документов возможно посредством Основной панели инструментов, горячих клавиш и контекстного меню. Подробнее смотрите Основная панель инструментов, Работа с экранными таблицами, Контекстное меню экранных таблиц, Навигатор экранных таблиц.

Однако, только для таблицы журналов документов, доступна расширенная фильтрация журналов документов (помимо стандартных возможностей по фильтрации, предоставляемых посредством навигатора экранных таблиц). Обеспечивается диалоговым окном Расширенный фильтр, вызываемым иконкой [image] (расширенный фильтр) на основной панели инструментов.

Принципиальное отличие от стандартного фильтра, обеспечивающего фильтрацию для любых экранных таблиц (в т.ч. таблицы документов), является то, что предоставляются возможности фильтрации по полям не только одной таблицы, а по полям двух таблиц: таблицы документов и таблицы проводок. Действительно, существует множество признаков и полей (помимо стандартных – номер, дата, тип документа), имеющих логическое отношение к общей характеристике документа, но не являющихся частью таблицы документов (сумма документа, количество, счет, субсчет, центр затрат и пр.). Именно такую возможность одновременной фильтрации по всем необходимым полям и критериям, имеющим логическое отношение к документам, но не являющихся частью одной таблицы документов и предоставляется Расширенным фильтром.

Еще одной отличительной особенностью является возможность включения и исключения каждого из критериев фильтра не его полным удалением, а независимым признаком, устанавливаемым для каждого критерия: («галочкой»), а также возможность выполнения фильтрации, без закрытия самого окна (специальная кнопка «Применить»).

Внешний вид окна:

Перечень полей и элементов:

- Период – критерий по дате документа, обеспечиваются конструкции: от … до … Для расширенного и удобного выбора периода дат используется кнопка [image] . По ее нажатию открывается контекстное окно расширенного выбора дат. Подробнее смотрите Задание периода выборки.

- Счет – критерий по бухгалтерскому счету.

- .ск – критерий по субсчету.

- Аналит. счет – критерий по аналитике 1-го уровня (виды материалов, ОС и пр.). Возможен выбор из справочника (в т.ч. множественный). Подробнее смотрите Множественный выбор из справочников.

- Центр затрат – критерий по аналитике 2-го уровня (юридические лица, дебиторы и кредиторы, работники, подразделения и пр.) Возможен выбор из справочника (в т.ч. множественный). Подробнее смотрите Множественный выбор из справочников.

- Операция – критерий по виду операции. Обеспечивается выбор из перечня операций (в т.ч. множественный). Подробнее смотрите Множественный выбор из справочников.

- Сумма – критерий по сумме. Также возможно в отдельном поле вводить процент отклонения.

- Количество – критерий по количеству.

- № документа – критерий по электронному номеру документа (присваиваемый системой).

- № док. ручной – критерий по номеру документа, заданному пользователем.

- Фильтровать – признак – «галочка», включающая и выключающая все остальные «галочки». Таким образом, обеспечивается возможность установки и снятия всего фильтра, без снятия каждого из критериев.

- Кнопка Прим. – выполняет установку или снятие всех фильтров в целом, без закрытия диалогового окна, исходя из заполнения каждого критерия, признаков включения/выключения каждого критерия и общего признака выключения/включения.

- Кнопка OK – выполняет установку или снятие всех фильтров в целом, закрывая диалоговое окно, исходя из заполнения каждого критерия, признаков включения/выключения каждого критерия и общего признака выключения/включения.

- Кнопка Отмена – закрывает диалоговое окно Расширенного Фильтра, без применения критериев фильтрации и условий включения/выключения.

Также, на форме диалогового окна присутствуют две дополнительные кнопки вида [image] , при нажатии которых диалоговое окно меняет свой вид, расширяясь и предоставляя пользователям дополнительные средства и возможности и элементы. В расширенном виде кнопки меняют свой вид на обратный [image] и позволяют выполнить обратное сужение (уменьшение) диалогового окна.

При нажатии 1-ой кнопки расширения, справа от основных полей расширенного фильтра появляются поля, предоставляющие возможность ручного написания любого дополнительного фильтра (синтаксис SQL):

Перечень полей:

- Фильтр DOCS – произвольный фильтр по таблице документов

- Фильтр CM – произвольный фильтр по таблице, содержащей проводки к документам (именно в ней содержится информация по суммам, видам аналитики и пр.).

При нажатии 2-ой кнопки расширения между перечнем критериев и кнопками OK, Отмена появляются две закладки. Закладка Текст фильтра предоставляет возможность пользователю видеть полный фильтр в текстовом формате (синтаксис SQL), исходя из всех включенных критериев:

Закладка Cautarea documentelor (поиск документов) используется в конфигурациях, где рабочие станции пользователей работают в удаленном режиме (сервер базы данных размещен удаленно) и при этом скорость канала передачи данных крайне низкая. У пользователей с подобной конфигурацией применяется общее ограничение по периоду просмотра для журналов документов, устанавливаемое через панель инструментов Период (Дополнительно смотрите Панель инструментов Период). В журналах документы показываются только за последние несколько дней (для ускорения времени отклика при слабом канале). В то же время при процедурах фильтрации должна обеспечиваться возможность просмотра и выборки документов и за период, отключенный для просмотра в журналах. Именно для таких случаев и используется эта вкладка. Представляет собой экранную таблицу, куда подгружается полный список документов и несколько управляющих кнопок.

Внешний вид:

Перечень полей и элементов:

- Исп. Фильтр – признак, определяющий надо ли применять заданные критерии фильтрации расширенного фильтра к списку документов.

- Кнопка Открыть – Подгружает (показывает) список документов в зависимости от выбранного признака «Исп. фильтр». Если признак не выбран, то показываются все документы, имеющиеся в базе данных (без учета ограничения на просмотр журналов документов, устанавливаемый через панель инструментов Период).

- Кнопка Пометить – Помечает активную строку списка документов ( [image] ). Документы, помеченные таким образом, будут показаны в журналах документов, вне зависимости от ограничений по периоду, установленных через панель инструментов период.

- Кнопка Убрать – Убирает отметки с документов, выставленные кнопкой Пометить.

- Кнопка Перейти – Позиционирует (делает активным) в таблице журнале документов, документ, выбранную строку Списка Документов, для того, чтобы помеченный документ не пришлось еще дополнительно искать в таблице журнала документов.

- Кнопка Закрыть – Выгружает (очищает) таблицу Списка Документов.

- Экранная таблица Список Документов – экранная таблица, содержащая список документов. Именно над записями этого Списка Документов выполняются действия вышеназванных кнопок. Документы вне периода просмотра, установленного через панель инструментов Период (т.е. не показываемые в журналах документов), помечаются следующим образом (цветом): . Документы, внутри периода просмотра, установленного через панель инструментов Период (т.е. показываемые в журналах документов), помечаются следующим образом: .

Дополнительно смотрите

Таблица журнала документов

, Основная панель инструментов.


Îáùåå îïèñàíèå äîêóìåíòîâ

Общее описание документов

Доступ к документам в системе Universal Accounting осуществляется в окне текущего журнала документов. Нижняя часть окна журнала – это содержание выбранной записи журнала, т.е. собственно сам первичный документ (его экранная форма). Подробнее смотрите Окно журнала документов.

Также между верхней частью окна (журналом) и нижней частью (документом) присутствует специальная документная панель инструментов, иконки на которой предоставляют средства по работе с документами. Возможность работы с документом также присутствует в пункте главного меню «Документ». Смотрите подробнее Документная панель инструментов, Меню Документ Главного меню.

Таким образом, документ в системе имеет следующий состав:

- Регистрационная запись в журнале документов

- Бухгалтерские проводки по документу

- Собственно сам документ (его содержание – первичные данные)

- Дополнительная произвольная информация по документу

- Информация о присоединенных OLE-объектах

Регистрационная запись в журнале документов содержит информацию, уникально идентифицирующую документ: код, тип, номер, дата и пр.:

Проводки по документу, содержание документа, дополнительная информация и информация об OLE-объектах документа содержатся в соответствующих 4-х закладках в нижней части окна журнала документов:

Содержание одной из четырех закладок (активной) и отображается в нижней части окна журнала документов для выбранной записи в верхней части (журнале).

Описание закладок:

- Проводки (Ctrl+1) – содержатся бухгалтерские проводки по документу. Экранная форма представления проводок стандартизирована путем использования Журнала Проводок. Подробнее смотрите Проводки по документам.

- Специфика (Ctrl+2) – представлен сам первичный документ (его содержание, экранная форма). Подробнее смотрите Экранные формы документов.

- Информация (Ctrl+3) – пользователю предоставляется возможность введения дополнительного произвольного комментария, и могут быть установлены некоторые дополнительные параметры документа. Подробнее смотрите Дополнительная информация по документам.

- Объект (Ctrl+4) – предоставляет возможность присоединения любых OLE-объектов к документу. OLE-объектами могут быть: отдельные документы-файлы различных форматов, в т.ч. Word, Excel и пр.; рисунки и фотографии; музыкальные файлы; видеоклипы и фильмы, а также другие OLE-объекты. Подробнее смотрите Присоединяемые OLE-объекты.


Ïðîâîäêè ïî äîêóìåíòàì

Проводки по документам

Закладка Проводки предоставляет доступ к бухгалтерским проводкам по данному документу. Также доступ возможен по горячей клавише Ctrl+1. Проводки представлены в виде Журнала Проводок – экранной таблицы, содержащей проводки.

Важное отличие от других систем – бухгалтерские проводки в системе Universal Accounting, помимо синтетического уровня (счета бухгалтерского учета), охватывают также полностью всю аналитику (аналитические уровни). Допускается аналитика 3-х уровней.

Проводки генерируются автоматически, на основании заполненной экранной формы документа, при выполнении специального действия – генерация проводок. Подробнее смотрите Экранные формы документов и Действия над документом.

Настройка проводок для каждого конкретного документа осуществляется администратором системы. В некоторых случаях на экранной форме документов пользователям предоставляется возможность выбора счетов бухгалтерского учета из справочника (в случае, если однозначное отнесение на какой-либо бухгалтерский счет для данного документа невозможно).

В связи с документно-ориентированным характером системы прямое редактирование и изменение журнала проводок запрещено. Для изменения проводок необходимо вначале выполнить соответствующие изменения на экранной форме документов (однако, возможен режим работы системы, аналогичный некоторым бухгалтерским программам, при котором экранные формы документов вовсе не задействуются и вся работа пользователей непосредственно производится с журналом проводок, через их прямой ввод и редактирование).

При работе с журналом проводок доступны все стандартные средства по работе с экранными таблицами. Подробнее смотрите Работа с экранными таблицами, Контекстное меню экранных таблиц, Навигатор экранных таблиц.

Журнал проводок условно делится на 2 области:

- Список проводок

- Дополнительные атрибуты и дополнительная аналитика

Список проводок, имеет следующую фиксированную структуру:

Каждая запись из списка проводок составляет отдельную проводку. В отличие от большинства других экранных таблиц в системе каждая запись в журнале проводок состоит из 2-х строк.

Первые семь колонок имеют одинаковую структуру для обеих строк, только верхняя строка содержит информацию о дебетовой составляющей проводки, а нижняя строка содержит информацию о кредитовой составляющей проводки. Последние две колонки имеют разное назначение для верхней и нижней строки проводки.

Перечень полей:

- Дт / Кт – бухгалтерский счет

- Ск – субсчет

- Аналитика – аналитика 1-го уровня

- Центр затрат – аналитика 2-го уровня

- Субсчет – аналитика 3-го уровня

- Вал. – наименование валюты

- Сумма в вал. – сумма в указанной валюте

- Кол-во / Цена – количество / цена

- Сумма GAAP / Сум. Лей – сумма в системе учета GAAP / сумма в леях

Дополнительные атрибуты проводок также представлены в виде двух строк и имеют следующий вид:

Содержимое данных полей показывается для выбранной записи журнала проводок. Логика их использования зависит от конкретной проводки и бухгалтерских счетов этой проводки. Всего имеется 7 пар полей. В зависимости от необходимости (логического содержания типа проводки) могут быть задействованы разнообразные наборы, с разным количеством атрибутов.

Аналогично Журналу проводок, дополнительные атрибуты представлены в виде двух строк. 5 пар полей, начиная со 2-ой пары, имеют одинаковую структуру для обеих строк, только верхняя строка содержит дополнительные атрибуты и аналитику, относящиеся к дебету, а нижняя – дополнительные атрибуты и аналитику, относящиеся к кредиту. 1-ая, 2-ая и последняя пара атрибутов относятся целиком к проводке, а не к дебетовой и кредитовой составляющим проводки.

Описание пар полей:

- № пр / № бпр – номер проводки внутри документа / номер базовой проводки внутри документа.

- № док – номер связанного документа.

- стр СК – информация по аналитике Субконто.

- № СМ – информация о номере «среза» проводок. В большинстве конфигураций данная пара полей не используется. По этому признаку проводки могут попадать в разные балансы или т.н. «срезы», «пачки», «пакеты» или «наборы» проводок. В основном, актуально для бюджетных организаций.

- Адата – аналитика типа Дата.

- К-во1 – информация типа Количество.

- Запрещ. / Дата – отображает «1», если проводки неактивны / дата документа.

Дополнительно смотрите Общее описание документов.


Ýêðàííûå ôîðìû äîêóìåíòîâ

Экранные формы документов

Закладка Специфика содержит экранную форму документа. Также доступ возможен по горячей клавише Ctrl+2. В основном экранные формы документов в системе Universal Accounting совпадают с реальными первичными документами, используемыми в организации, которые требуется вводить в информационную базу: платежное поручение, счет, приходная/расходная налоговая или товарно-транспортная накладная, кассовые ордера и т. д.

Экранные формы документов значительно отличаются друг от друга и зависят от представления первичных документов, которым они соответствуют. Поэтому закладка Специфика не имеет четкой структуры (как другие закладки) и внешний вид, набор полей, реквизитов прочих параметров зависят от вида первичного документа.

Можно выделить несколько элементов интерфейса, используемых при формировании экранных форм документов:

- Шапка документа – содержит набор полей (текст, дата или выпадающий список), общих для всего документа

- Табличная часть документа – содержит многострочную часть документа. Внизу таблицы может присутствовать строка итогов.

- Вкладки – позволяет группировать элементы шапки и табличные части документа

- Структуры типа «Master-Detail» – для каждой строки Master-таблицы (главная таблица) показывается отдельная Detail-таблица (подчиненная таблица). Данная структура может иметь несколько уровней вложенности. Может быть горизонтальное, вертикальное представление данной структуры или их комбинация.

Также могут присутствовать другие элементы: управляющие кнопки и пр. Однако возможна и обратная ситуация, когда документ не будет содержать каких-либо из вышеназванных элементов (или даже всех элементов – тогда экранная форма вообще отсутствует).

Далее представлены некоторые экранные формы первичных документов, демонстрирующие вышеперечисленные элементы интерфейса:

Подробно экранные формы всех видов документов представлены в специализированных руководствах и описаниях по участкам, где данные документы используются.

Дополнительно смотрите Общее описание документов.


Äîïîëíèòåëüíàÿ èíôîðìàöèÿ ïî äîêóìåíòàì

Дополнительная информация по документам

Закладка Информация предоставляет возможность ввода дополнительного, произвольного текстового комментария. Также доступ возможен по горячей клавише Ctrl+3. Для этого предназначено поле Пояснение.

Также данная закладка содержит еще два поля: Поле-«галочка» – установка некоторого, дополнительного признака и Поле даты – для ввода некоторой, дополнительной даты. Их использование зависит от логического содержания документов.

Дополнительно смотрите Общее описание документов.


Ïðèñîåäèíÿåìûå OLE-îáúåêòû

Присоединяемые OLE-объекты

Вкладка Объект предназначена для прикрепления к документу файлов, выполненных в других приложениях Windows – OLE-объектов. Также доступ возможен по горячей клавише Ctrl+4. OLE-объект – это часть текущего документа, которая создана другим Windows-приложением. Такой OLE-объект является полноценной частью документа с той лишь разницей, что для редактирования такого объекта будет загружено приложение (внутри текущего приложения), которым этот объект был создан. Поддержка внедренных OLE-объектов является одной из универсальных возможностей программ, работающих в операционной системе Windows.

На данной закладке имеются:

- Специальная панель инструментов по работе с OLE-объектами

- Область показа OLE-объектов (для текущего объекта из таблицы)

- Таблица с перечнем объектов (имена файлов и комментарии к ним)

Добавление, изменение и удаление записей в таблице (списке OLE-объектов), которая представляет собой стандартную экранную таблицу, осуществляется аналогично работе со всеми экранными таблицами в рамках системы. В режиме редактирования активизируется специальная панель инструментов по работе с OLE-объектами, расположенная выше области показа OLE-объектов.

- [image] Вставка нового объекта – открывает соответствующее стандартное окно Windows, содержащее перечень доступных типов OLE-объектов (зависит от настройки операционной системы и установленных программ) и способ создания OLE-объекта (новый или из существующего файла).

- [image] Корректировка объекта – позволяет осуществлять корректировку OLE-объекта, при этом в основную систему (в данном случае – Universal Accounting) встраиваются меню и панели инструментов из программы, связанной c данным типом OLE-объектов.

- [image] Открытие окна объекта – открывает программу, связанную с данным типом OLE-объектов, в отдельном окне.

- [image] Закрытие объекта – завершает режим корректировки объекта.

- [image] Исправление свойств объекта – открывает диалоговое окно свойств для данного типа файлов (содержимое зависит от типа файлов).

- [image] Удаление объекта – удаляет OLE-объект.

Дополнительно смотрите Общее описание документов.

Для общего изучения принципов использования OLE-объектов обратитесь к справочному руководству по операционной системе Windows.


Ìåíþ Äîêóìåíò Ãëàâíîãî ìåíþ

Меню Документ Главного меню

Меню Документ Главного меню предоставляет функции и средства по работе с документами. В режиме редактирования документов в основном соответствует средствам, предоставляемым через Документную панель инструментов. Подробнее смотрите Документная панель инструментов. Меню Документ имеет 2 разных представления, в зависимости от режима документа:

- Режим просмотра документов

- Режим редактирования документов

Внешний вид меню Документ в режиме просмотра документов:

Состав меню Документ в режиме просмотра документов:

- Правка – правка документа (режим редактирования).

- Новый док. (Ctrl+Minus) – создание нового документа (открывается список доступных для данного журнала документов).

- Дублировать (Ctrl+Plus) – создание нового документа на основе текущего. Все содержимое документа, кроме бухгалтерских проводок, будет продублировано.

- Док-т – проводки (Ctrl+`) – быстрое переключение режимов переход в режим редактирования.

Внешний вид меню Документ в режиме редактирования:

Состав вид меню Документ в режиме редактирования:

- Сохранить – сохраняет документ.

- Отмена – отменяет все сделанные изменения и завершает режим редактирования документа.

- Удал. пр-ки – удаляет все проводки из документа.

- Выполнить (F9) – позволяет выполнить Действия над документом. Подробнее смотрите Действия над документом.

- Специальн. – Данный пункт меню позволяет устанавливать особые состояния документа и проводок. Подробнее смотрите Пункт Специальные меню Документ.

- Печать (Ctrl+P) – позволяет выполнять формирование печатных форм, определенных для данного документа. Подробнее смотрите Печатные формы документов.

- Фактура (F11) – вызывает дополнительную форму документа, предназначенную для ввода всех необходимых дополнительных реквизитов, используемых в ТТН, Налоговых накладных и некоторых других видах документов. Подробнее смотрите Дополнительная форма документа.

- Итоги (Ctrl+T) – предоставляет информацию об итогах документа по счетам. Также возможен вывод произвольной расчетной информации. Подробнее смотрите Расчет итогов по документу.

- Док-т – проводки (Ctrl+`) – быстрое переключение режимов переход в режим редактирования.

Как было сказано выше, большинство средств также доступно через Документную панель инструментов. Подробнее смотрите Документная панель инструментов.


Ïóíêò Ñïåöèàëüíûå ìåíþ Äîêóìåíò

Пункт Специальные меню Документ

Пункт Специальные меню Документ позволяет устанавливать особые состояния документов и проводок. Большинство данных настроек визуально отображаются в таблице журнала операций различными графическими средствами. Подробнее смотрите Таблица журнала документов.

Перечень элементов:

- Состояние документа, Документ неверен – принудительно устанавливает состояние документа – Неверен. Означает, что документ был сохранен без проведения или перепроведения проводок либо сделан неактивным. Визуально, в таблице журнала документов отображается [image] , в начале строки.

- Состояние документа, Документ верен – принудительно устанавливает состояние документа – Верен. Нормальное состояние документов. Визуально, в таблице журнала документов отображается [image] , в начале строки.

Диагональная полоса зелёного цвета, возникает только в том случае, если документ редактируется с помощью следующих шагов: Создать документ, Бухгалтерские проводки и Сохранить. Зелёный цвет означает, что часть данных, введённых через интерфейс документа и сохранённые бухгалтерские записи не совпадают. Зелёный исчезает, когда пользователь уже входит в документ и, не выполняя действие бухгалтерских записей, в итоге нажимает Сохранить или нажимает ENTER на клавиатуре в верхней главной таблице журнала в списке документов вместо Отмена или клавишу ESC на клавиатуре. После этого зелёный цвет меняется на красный. Это означает, что существует риск того, что данные, видимые в интерфейсе документа, могут уже не совпадать с бухгалтерскими записями. Зелёный цвет указывает на то, что в этом документе есть актуальные проводки.

- Состояние проводок, Проводки активны – не используется.

- Состояние проводок, Проводки неактивны – не используется.

- Состояние проводок, Проводки частично активны – не используется.

- Состояние проводок, Документ не сохранен в журнале проводок – не используется.

- OK – применяет к текущему документу настройки и закрывает окно особых действий.

- Отмена – отменяет установку специальных состояний (закрывает окно).

- Прим. – применить к текущему документу выбранные настройки (без закрытия окна).

Дополнительно смотрите Меню Документ Главного меню.


Äîêóìåíòíàÿ ïàíåëü èíñòðóìåíòîâ

Документная панель инструментов

Между верхней частью окна текущего журнала (собственно журналом) и нижней частью (документом) присутствует специальная документная панель инструментов, иконки на которой предоставляют функции по работе с документами и специальные средства: печатные формы документов, итоги по документу, действия над документом, дополнительные данные для печатных форм. Документная панель инструментов имеет разный вид, в зависимости от режима документа:

- Режим просмотра

- Режим редактирования

В режиме просмотра Документная панель инструментов имеет следующий вид:

Доступны следующие инструменты:

- Правка – правка документа (режим редактирования).

- Новый док. (Ctrl+Minus) – создание нового документа (список доступных для данного журнала документов).

- Дублир. док. (Ctrl+Plus) – создание нового документа на основе текущего. Все содержимое документа кроме бухгалтерских проводок будет продублировано.

- [image] – для администраторов системы.

При переходе в режим редактирования Документная панель инструментов приобретает следующий вид:

Доступны следующие инструменты:

- Сохранить – сохраняет документ.

- Отменить – отменяет все сделанные изменения и завершает режим редактирования документа.

- Удал. пр-ки – удаляет все проводки из документа.

- (частично) – удаляет не основные (производные) проводки из документа.

- Выполнить (F9) – позволяет выполнить Действия над документом. Подробнее смотрите Действия над документом.

- [image] Печать (Ctrl+P) – позволяет выполнять формирование печатных форм, определенных для данного документа. Подробнее смотрите Печатные формы документов.

- [image] Итоги (Ctrl+T) – предоставляет информацию об итогах документа по проводкам. Также возможен вывод произвольной расчетной информации. Подробнее смотрите Расчет итогов по документу.

- [image] Действия (F9) – позволяет выполнять разнообразные действия над документом. Одно из самых распространенных – генерация проводок. Также возможны автоматическое заполение документа, пересчет строк, вставка данных из справочников, форм и учетных регистров, выполнение других действий. Подробнее смотрите Действия над документом.

- [image] или [image] Активация/Дезактивация – позволяет дезактивировать документ (по умолчанию документ активен). Неактивный документ – документ, проводки которого не видны для отчетов Неактивное состояние документа также обозначается голубым цветом в таблице журнала документов. Дополнительно смотрите Таблица журнала документов.

- [image] Фактура (F11) – вызывает дополнительную форму документа, предназначенную для ввода всех необходимых дополнительных реквизитов, используемых в ТТН, Налоговых накладных и некоторых других видах документов. Также эти реквизиты могут использоваться в качестве дополнительной аналитики. Подробнее смотрите Дополнительная форма документа.

- [image] – для администраторов системы.


Ïå÷àòíûå ôîðìû äîêóìåíòîâ

Печатные формы документов

Через пункт Печать меню Документ главного меню или инструмент [image] на Документной панели инструментов или горячей клавишей Ctrl+P вызывается окно выбора печатных форм документа:

В случае однозначности выбора (к документу привязана только одна печатная форма) печатная форма может быть сформирована без открытия окна выбора печатных форм. Возможны варианты, когда печатная форма может быть сформирована только после осуществления некоторых установленных действий над документом (например, генерация проводок), в этом случае перед выводом на экран окна выбора печатных форм или непосредственно печатной формы может быть показано окно выбора действий над документом. Подробнее смотрите Действия над документом. Также вывод печатных форм и/или выполнение действий может вызывать процедуру закрытия документа (переход в режим просмотра).

Некоторые печатные формы требуют наличия дополнительной информации (например, ТТН, Налоговые накладные). Для ввода этой информации применяется т.н. Дополнительная форма документа. Подробнее смотрите Дополнительная форма документа.

В окне выбора печатных форм имеются следующие элементы:

- Список печатных форм – именованный перечень печатных форм, доступных для данного документа. Рядом с названием печатной формы имеется элемент «галочка», определяющий, какие именно формы будут выведены на экран ( [image] или [image] ). Таким образом, обеспечивается одновременный вывод на экран нескольких печатных форм.

- Кнопка OK – запускает процедуры генерации и вывода на экран выбранных печатных форм документов (каждая печатная форма выводится в отдельном дочернем окне).

- Кнопка Отмена – закрывает окно выбора печатных форм.

- Кнопка Прим. (Применить) – аналогична кнопке OK.

Само окно печатной формы, в рамках системы, также стандартизировано. Работа с печатными формами (использование, редактирование и пр.) осуществляется одинаково как для печатных форм документов, так и для печатных форм отчетов. Подробнее смотрите Печатные формы отчетов – общее описание.

Также возможен прямой вывод печатной формы документа (или отчета) прямо в Microsoft Excel или Word (настраивается администратором системы). Тогда вся последующая работа с такой печатной формой осуществляется в рамках и по правилам среды Excel или Word.

Дополнительно смотрите Меню Документ Главного меню, Документная панель инструментов.


Ðàñ÷åò èòîãîâ ïî äîêóìåíòó

Расчет итогов по документу

Через пункт Итоги меню Документ главного меню или через инструмент [image] на Документной панели инструментов, а также посредством горячей клавиши Ctrl+T вызывается окно Расчета итогов по документу:

Используется для наглядного показа итогов по каждому счету (отдельно для кредита и дебета), использованному в проводках документа (после формирования проводок). Таким образом, возможна удобная проверка общих сумм по проводкам.

Окно содержит 2 закладки:

- Из ГК – закладка по умолчанию, с расчетом итогов (обороты) по дебету и кредиту всех бухгалтерских счетов, использованных в проводках документа.

- Special – вывод произвольных итогов и выполнение с ними дополнительных вычислений. Настраивается администратором системы.

Также окно расчета итогов содержит следующие элементы:

- Таблицу, содержащую итоги – перечень всех показателей, в зависимости от выбранной закладки и числовой результат.

- Кнопка OK – закрывает окно выбора печатных форм.

- Кнопка Отмена – аналогична кнопке OK.

- Кнопка Прим. (Применить) – аналогична кнопке OK.

Дополнительно смотрите Меню Документ Главного меню, Документная панель инструментов.


Äåéñòâèÿ íàä äîêóìåíòîì

Действия над документом

Через инструмент [image] на Документной панели инструментов, а также посредством горячей клавиши F9 вызывается окно выбора Действий над документом:

К данному окну привязаны все действия, так или иначе связанные с данным документом. Наиболее распространенное действие – генерация проводок по документу. Также могут присутствовать следующие типовые действия: автоматическое заполнение таблицы, различные расчеты внутри самого документа и пр.

Возможно выполнение нескольких действий одновременно (даже всех), при этом порядок перечисления действий в окне выбора указывает на последовательность их выполнения (определяется администратором). Также применяются порядковые номера действий, причем если в списке присутствуют несколько действий с одинаковым номером, то обычно это указывает на взаимоисключающий характер их выполнения.

Автоматическое выполнение действий, привязанных к документу (например, генерация проводок) может выполняться при попытке распечатать некоторую печатную форму документа или при выходе из документа с сохранением. Также возможна настройка и обратным образом: при выполнении действий последует автоматическое закрытие документа (и/или формирование печатных форм).

В окне выбора действий имеются следующие элементы:

- Список действий – именованный перечень действий, доступных для данного документа. Рядом с названием печатной формы имеется элемент «галочка», определяющий, какие именно действия будут выполнены ( [image] или [image] ). Таким образом, обеспечивается одновременное выполнение нескольких действий (в порядке их присутствия в списке).

- Кнопка OK – запускает процедуры выполнения действий.

- Кнопка Отмена – закрывает окно выбора действий.

- Кнопка Прим. (Применить) – аналогично кнопке OK.

Дополнительно смотрите Документная панель инструментов.


Äîïîëíèòåëüíàÿ ôîðìà äîêóìåíòà

Дополнительная форма документа

Через пункт Фактура меню Документ главного меню или инструмент [image] Документной панели инструментов, а также посредством горячей клавиши F11, вызывается окно дополнительной формы документа:

Дополнительная форма документа предоставляет возможность ввода и сохранения дополнительной информации, обычно необходимой только для правильного и полного заполнения печатных форм документов и не имеющей значения для проводок и другой аналитики в системе, но в некоторых конфигурациях и эта информация может быть использована как дополнительная аналитика проводок (например, номер контракта).

В основном применяется в ТТН, Налоговых накладных, Счетах на Оплату, Путевых Листах, Доверенностях (при необходимости генерации печатных форм этих документов из системы).

Содержит большое количество разнообразных полей: текстовые, выбор из нескольких вариантов, выпадающие списки (в т.ч. привязанные к некоторым справочникам) и пр. Варианты заполнения и смысловая нагрузка тех или иных полей зависят от типа конкретного документа.

Помимо полей, содержит также элементы:

- Кнопка OK – сохраняет всю информацию из заполненных полей в документе (сохранение всего документа при этом не происходит) и закрывает окно дополнительной формы.

- Кнопка Отмена – закрывает окно дополнительной формы без сохранения.

Дополнительно смотрите Меню Документ Главного меню, Документная панель инструментов.


Ñïðàâî÷íèêè ñèñòåìû è ìåíþ Ñïðàâî÷íèêè ãëàâíîãî ìåíþ

Справочники системы и меню Справочники главного меню

Через Справочники в системе Universal Accounting задаются условно-постоянные перечни объектов учета, операции над которыми реализуются через документы (подразделения, работники, товары, материалы и пр.).

Справочники бывают 3-х основных типов:

- Справочник бухгалтерских счетов (План счетов)

- Аналитические Справочники

- Системные Справочники

Справочник бухгалтерских счетов (План Счетов) – важнейший справочник системы. В соответствии с принципами организации Universal Accounting, счета синтетического учета (т.е. План счетов) являются своеобразным «стержнем», к которому жестко привязываются счета аналитического учета (аналитические справочники). Это обеспечивает единообразие всех видов данных (оперативных, бухгалтерских, аналитических). Здесь же пользователь может увидеть дополнительные характеристики счетов (количественный учет, учет в валюте). Подробнее смотрите Справочник бухгалтерских счетов.

Аналитические справочники на самом деле представляют собой единый справочник всех видов аналитики (аналитических счетов) в системе. Стандартное разделение осуществляется по т.н. Типам и Фильтрам. Cуществует и более развитый механизм логического разделения, позволяющий формировать более сложные, составные или даже формульные условия. В соответствии с этим, в Плане счетов за тем или иным счетом определяется фильтр (или их комбинации). В результате, пользователю, в зависимости от контекста (например, выбранного счета) доступна та или иная часть общего аналитического справочника (или несколько его частей), в свою очередь представляющая логически-независимый справочник. Аналитические справочники допускают многоуровневые группировки и т.н. Карточки аналитики, которые содержат множество различных полей и допускают внесение разнообразной дополнительной информации. Подробнее смотрите Использование аналитических справочников.

Системные справочники являются вспомогательными по отношению к аналитическим справочникам, документам, формам. Данные из этих справочников не попадают в учетные регистры. Описывают элементарные массивы данных (города, типы контрактов и пр.). Так же физически представляют собой единую таблицу, с фильтрами, по которым и происходит разделение на логически-независимые системные справочники. Подробнее смотрите Использование системных справочников.

Доступ к справочникам в системе Universal Accounting реализуется контекстно, прямо внутри документов, форм, отчетов. Контекстный справочник, открытый внутри документа, является полноценным справочником, записи которого доступны для добавления, изменения, удаления (может быть запрещено, исходя из прав пользователя). В то же время, возможно открытие и работа со справочниками в отдельных окнах, посредством меню Справочники Главного меню:

Содержит следующие пункты:

- Счета (Ctrl+F2) – доступ к справочнику счетов. Подробнее смотрите Справочник бухгалтерских счетов.

- Специальный – доступ через подменю к аналитическим справочникам, заданным не элементарными фильтрами, а более сложными составными или формульными условиями. Подробнее смотрите Использование аналитических справочников.

- Стандартный – доступ через подменю к аналитическим справочникам, логическое разделение которых задано стандартными фильтрами. Подробнее смотрите Использование аналитических справочников.

- Справочник … - открывает специальное диалоговое окно проверки справочников, в котором показываются все специальные и стандартные аналитические справочники, а также системные справочники. Подробнее смотрите Окно проверки справочников.


Ñïðàâî÷íèê áóõãàëòåðñêèõ ñ÷åòîâ

Справочник бухгалтерских счетов

Справочник бухгалтерских счетов (План счетов) – важнейший справочник системы. В соответствии с принципами организации Universal Accounting, счета синтетического учета (т.е. План счетов) являются своеобразным «стержнем», к которому жестко привязываются счета аналитического учета (аналитические справочники). Это обеспечивает единообразие всех видов данных (оперативных, бухгалтерских, аналитических) и возможность получения оборотно-сальдовых отчетов в разрезе любых синтетических и аналитических счетов и субсчетов. Здесь же пользователю доступна информация о дополнительных характеристиках того или иного счета: количественный учет, учет в валюте, а также некоторые другие настройки.

Доступ к Плану счетов возможен через пункт Счета меню Справочники главного меню, посредством горячей клавиши Ctrl+F2, а также контекстно, внутри документов и форм. Просмотр Плана Счетов удобен пользователям с целью уточнения бухгалтерских счетов и проверки аналитики, подключенной к синтетическим счетам. Также, ознакомление со строением Плана счетов позволит понять общие принципы организации и функционирования данных в системе Universal Accounting.

Окно Плана счетов состоит из 3-х частей:

- Дерево счетов

- Основная таблица счетов

- Дочерняя таблица субсчетов

Таблицы Плана счетов (основная таблица счетов и дочерняя таблица субсчетов) представляют собой стандартизированные объекты – экранные таблицы, инструменты для работы с которыми едины для всей системы. Таким образом, возможно использование стандартных горячих клавиш, контекстного меню или навигатора экранных таблиц. Подробнее смотрите Работа с экранными таблицами, Контекстное меню экранных таблиц, Навигатор экранных таблиц.

Дерево счетов представляет древовидную структуру плана счетов, в которой верхние узлы дерева представляют собой группы счетов, подузлы – счета первого уровня (3 цифры). Дерево счетов служит для фильтрации счетов 2-го уровня (4 цифры), которые представлены в основной таблице счетов. Таким образом, при выборе в Дереве счетов определенного подузла, в основной таблице счетов будут показаны только счета 2-го уровня, относящиеся к выбранному счету 1-го уровня. При выборе верхней, обобщающей строки Дерева – План счетов, в таблице счетов будет показан полный перечень счетов 2-го уровня.

В Основной таблице счетов представлен перечень счетов 2-го уровня. Основные поля – номер счета (4 цифры) и его название. Также, в основной таблице счетов осуществляется привязка аналитических счетов (видов аналитик) к синтетическим счетам. Всего возможны 3 основных уровня аналитики, соответственно этому в таблице присутствуют 3 пары полей, каждая пара определяет фильтры своего уровня аналитики. Поля, составляющие пару – Тип и Фильтр. Поле Тип определяет тип аналитики, который, в свою очередь, определяет карточку элемента. Существует 6 стандартных типов аналитики и соответственно 6 вариантов стандартных карточек, которые позволяют хранить разнообразную дополнительную информацию. Также администратором системы могут настраиваться дополнительные типы аналитики и дополнительные карточки. Поле Фильтр – фильтр на едином аналитическом справочнике, осуществляющий разделение на логически независимые справочники, при этом могут допускаться и составные фильтры. Помимо этого, возможны случаи, когда логически независимый справочник задан не элементарным фильтром, а более сложными составными или формульными условиями.

Уровни Аналитики:

- 1-ый уровень – Аналитика, располагаются объекты учета: товары, материалы, основные средства и пр.

- 2-ой уровень – Центры Затрат, располагаются субъекты учета: организации, физические лица, подразделения, работники и пр.

- 3-ий уровень – Субконто, не имеет жесткого закрепления и является комбинированным.

В системе должно обеспечиваться относительно жесткое закрепление аналитики по уровням, например, если для счета необходимо ведение аналитического учета только по субъектам учета, то 1-ый уровень должен оставаться пустым и заполняется 2-ой уровень. Данная привязка позволяет обеспечить логическую стройность данных, быстроту и простоту выполнения запросов и отчетов.

Помимо этого, в основной таблице счетов пользователю доступна дополнительная информация по счетам: ведение количественного учета, ведение учета по счету в валюте, активный / пассивный, балансовый / забалансовый.

Признак активный / пассивный для выбранного счета определяет, по дебету или по кредиту будет определяться сальдо.

Признак балансовый / забалансовый показывает, будет ли данный счет включен в баланс или нет. Понятие «забалансового счета» в системе Universal Accounting шире, чем в традиционном бухгалтерском учете. Допускается вводить рабочие забалансовые счета, используемые для вспомогательных целей (например, хранение суммы необлагаемого дохода работника или учета пробега автомобилей).

Для выбранной строки в основной таблице счетов (для выбранного счета 2-го уровня) отображается дочерняя таблица субсчетов. В ней представлен табличный перечень субсчетов, с указанием номера, названия и некоторых параметров. Субсчета используются при необходимости получения более детальной информации или разделения единого счета по некоторому признаку. Отличие от аналитических счетов, которые также используются для детализации по видам аналитик, состоит в том, что субсчета представляют собой элемент синтетического учета.

Дополнительно смотрите Справочники системы и меню Справочники главного меню.


Îêíî ïðîâåðêè ñïðàâî÷íèêîâ

Окно проверки справочников

Пункт меню Справочник…открывает диалоговое окно проверки справочников, в котором показываются все специальные и стандартные аналитические справочники, а также системные справочники.

В диалоговом окне имеются 6 вкладок:

- Новый – древовидный перечень логически независимых аналитических справочников, заданных сложными составными или формульными условиями, а не элементарными фильтрами.

- Старый – дерево-список, где представлены 6 стандартных типов аналитик (для этих 6 типов предопределены карточки элементов), и для выбранного типа аналитики в таблице отображаются все стандартные элементарные фильтры, формирующие логически независимые аналитические справочники.

- Факт. – внешне похожа на вкладку Старый, но здесь представлены все фактически имеющиеся в базе данных типы аналитик (а не только стандартные 6) и для каждого типа аналитики – табличный список фактически имеющихся фильтров, формирующих аналитические справочники.

- Любой – на данной вкладке имеются поля для ввода типа аналитики и фильтра, что позволяет не искать требуемый аналитический справочник в списках, а явно указать тип и фильтр, если эта информация известна.

- SysS Факт. – дерево-список, где представлены все, фактически имеющиеся в базе данных системные типы, и для выбранного типа – все системные фильтры, формирующие логически независимые системные справочники.

- SysS Любой – на данной вкладке имеются поля для ввода системного типа и системного фильтра, что позволяет не искать требуемый системный справочник в списках, а явно указать тип и фильтр, если эта информация известна.

Также на форме диалогового окна имеются, общие для всех закладок, элементы:

- Специальная кнопка Проверка – для всех вкладок, позволяет открыть в отдельном окне выбранный в списке или явно указанный аналитический или системный справочник.

- Кнопка OK – закрывает диалоговое окно.

- Кнопка Отмена – закрывает диалоговое окно.

Примеры всех 6 вкладок:

Дополнительно смотрите Справочники системы и меню Справочники главного меню.


Èñïîëüçîâàíèå àíàëèòè÷åñêèõ ñïðàâî÷íèêîâ

Использование аналитических справочников

Аналитические справочники на самом деле представляют собой единый справочник всех видов аналитик (аналитических счетов) в системе. Стандартное разделение осуществляется по т.н. Типам Аналитик и Фильтрам, существует и более развитый механизм логического разделения, позволяющий формировать более сложные, составные или даже формульные условия. В соответствии с этим, В Плане счетов за тем или иным счетом определяется фильтр (или их комбинации). В результате, пользователю, в зависимости от контекста, доступна та или иная часть общего аналитического справочника (или несколько частей), в свою очередь, представляющая логически-независимый справочник. Аналитические справочники допускают многоуровневые группировки и Карточки элементов, которые содержат множество различных полей и допускают внесение разнообразной дополнительной информации.

Стандартными 6 типами аналитик являются:

- O – Лица

- F – Основные средства

- M – Материалы

- P – Продукция

- L – Операции

- T – Разное

Пример аналитического справочника:

Работа пользователей с данными этих справочников осуществляется внутри документов, аналитических справочников, форм. В то же время, возможно открытие любого аналитического справочника, существующего в системе, в отдельном дочернем окне, причем несколькими способами: через пункты Специальный и Стандартный меню Справочники, а также через диалоговое окно проверки справочников. Дополнительно смотрите Справочники системы и меню Справочники главного меню, Окно проверки справочников.

Сами таблицы аналитических справочников представляют собой стандартизированный объект – экранная таблица, посредством которого, в рамках системы, представляются все табличные данные и информация. Исходя из этого, использование системных справочников возможно посредством стандартных горячих клавиш и контекстного меню. Также, непосредственной частью справочника является Навигатор экранных таблиц, представляющий специальную панель инструментов. Подробнее смотрите Работа с экранными таблицами, Контекстное меню экранных таблиц, Навигатор экранных таблиц.

Помимо стандартных средств Навигатора таблиц, на панели инструментов аналитических справочников расположены некоторые дополнительные инструменты:

- [image] Группы – открывает и скрывает Панель группировок данного аналитического справочника. Подробнее смотрите Панель группировок аналитических справочников.

- [image] Карточка – открытие детальной Карточки элемента справочника. Подробнее смотрите Карточки элементов аналитических справочников.

- [image] Закрыть – закрывает контекстное или дочернее окно аналитического справочника.

Дополнительно смотрите Справочники системы и меню Справочники главного меню.


Ïàíåëü ãðóïïèðîâîê àíàëèòè÷åñêèõ ñïðàâî÷íèêîâ

Панель группировок аналитических справочников

В связи с тем, что в аналитических справочниках содержится достаточно сложная, множественная информация, а также в связи с тем, что количество позиций аналитического справочника (например, материалов) достаточно часто очень велико, существует потребность в группировании элементов аналитических справочников. Это достигается путем использования Панели Группировок, которая является частью окна аналитических справочников. Открывается / скрывается (слева от таблицы справочника) кнопкой [image] на панели инструментов аналитических справочников.

Внешний вид панели группировок:

Панель группировок имеет динамический размер и подведя указатель мыши к разделительной линии панели группировок и таблицы справочника, захватив ее нажатием левой кнопки мыши, можно уменьшать или увеличивать видимые области панели группировки или таблицы аналитического справочника.

Состав Панели группировок:

- Поле выбора группировки (название группировки)

- Специальная панель инструментов

- Многоуровневое дерево с перечнем групп и подгрупп

- Поле типа «галочка» – параметр выбора дерева группировки

Система Universal Accounting допускает сознание множественных группировок и их одновременное наложение на записи аналитического справочника (например, группировка справочника товаров по товароведческим группам и отдельная группировка по их расположению). Соответственно этому, имеется специальное поле выбора группировки – [image] , показывающее текущую выбранную группировку. Представляет собой поле с выпадающим списком доступных группировок.

На специальной панели инструментов – [image] расположены средства для работы с группировками и деревом групп и подгрупп:

- [image] Добавить узел – добавляет группы (узлы дерева группировки) на текущем уровне (в текущей группе).

- [image] Удалить узел – удаляет текущую выбранную группу (узел дерева группировки) любого уровня, вместе со всеми подгруппами.

- [image] Добавить подузел – добавляет подгруппу к текущей выбранной группе (подузел дерева группировки) на уровень ниже от текущего уровня.

- [image] Удалить все подузлы – удаляет все подгруппы текущей группы (подузлы дерева группировки) любого уровня.

- [image] Обновить – обновляет структуру справочника.

- [image] Режимы фильтра – позволяет выбирать режимы фильтрации таблицы аналитического справочника: а) фильтр выключен – показываются все записи таблицы, но записи текущей группы выделяются особым цветом шрифта; б) фильтр включен – в таблице показываются только записи, относящиеся к выбранной группе.

- [image] Добавить группировку – добавление новой группировки, после чего она становится доступной для выбора в поле выбора группировок. Вызывается специальное диалоговое окно, где вводятся все необходимые сведения.

- [image] Изменить группировку – позволяет изменить параметры текущей выбранной группировки в специальном диалоговом окне.

Также, при контекстном открытии любого аналитического справочника из окна отчетов внизу панели группировок дополнительно показывается кнопка Выбрать, позволяющая выбрать в качестве фильтра или условия отчета не определенную позицию справочника, а всю текущую группу текущей группировки или набор групп.

Дополнительно смотрите Использование аналитических справочников.


Êàðòî÷êè ýëåìåíòîâ àíàëèòè÷åñêèõ ñïðàâî÷íèêîâ

Карточки элементов аналитических справочников

Карточки элементов аналитических справочников являются диалоговыми окнами сложного строения (множество полей, закладки), предоставляющие пользователю возможность внесения разнообразной дополнительной информации по каждой записи аналитических справочников.

Карточка текущей записи текущей аналитической таблицы открывается при нажатии кнопки [image] на панели инструментов аналитических справочников либо при нажатии горячей клавиши F3.

В системе имеется несколько типов карточек, в соответствии с типами аналитик:

- Карточка субъектов учета: лиц, работников, организаций, подразделений, банков (тип аналитики O)

- Карточка ОС и нематериальных активов (тип аналитики F)

- Карточка материалов, МБП, готовой продукции и товаров (M, P, T)

- Карточка операций (L)

Несмотря на наличие нескольких типов карточек, все они имеют общий принцип построения:

- Диалоговое окно карточки элемента условно разделено на две части: верхнюю и нижнюю.

- Верхняя часть содержит поля для ввода основных атрибутов – код, альтернативный код, название, альтернативное название, единицы измерения и пр. Эти поля едины для всех типов карточек и фактически представляют собой саму запись аналитического справочника. В зависимости от контекста верхняя часть Карточки может отсутствовать (например, при открытии Карточки из Плана Счетов).

- Нижняя часть содержит специализированные для каждого типа карточки атрибуты. Поля для ввода значений представляют собой либо поля ввода, либо поля выбора из списков, системных справочников, либо других аналитических справочников. Весь набор полей может быть разбит по нескольких закладкам, в соответствии с логическим смыслом полей и для обеспечения простоты работы.

- Для сохранения информации диалоговое окно карточки необходимо закрыть, нажав кнопку ОК, без сохранения информации окно закрывается нажатием кнопки Cancel. Эти кнопки расположены в самом верху диалогового окна.

- Внизу окна расположено несколько кнопок-инструментов, позволяющих выполнять действия с самими записями аналитического справочника: – удаление записи, [image] – сохранение редактирования, [image] – отмена редактирования. В зависимости от вариантов открытия карточки, некоторые из этих инструментов (или даже все) могут быть недоступны.

- Администратором системы может быть сделана настройка тех или иных форм карточек, путем скрытия или показа различных полей и закладок.

Примеры карточек:

Дополнительно смотрите Использование аналитических справочников.


Èñïîëüçîâàíèå ñèñòåìíûõ ñïðàâî÷íèêîâ

Использование системных справочников

Системные справочники являются вспомогательными по отношению к аналитическим справочникам, документам, формам. Данные из этих справочников не попадают в учетные регистры. Описывают элементарные массивы данных (города, типы контрактов и пр.).

Физически, представляют собой единую таблицу, с типами и фильтрами, по которым и происходит разделение на логически-независимые системные справочники. Данное логическое разделение настраивается администратором системы.

Пример системного справочника:

Работа пользователей с данными этих справочников осуществляется внутри документов, аналитических справочников, форм. В то же время, возможно открытие любого системного справочника, существующего в системе, в отдельном дочернем окне, через специальное окно проверки справочников. Подробнее смотрите Окно проверки справочников.

Сами таблицы системных справочников представляют собой стандартизированный объект – экранная таблица, посредством которого, в рамках системы, представляются все табличные данные и информация. Исходя из этого, использование системных справочников возможно посредством стандартных горячих клавиш и контекстного меню. Также, непосредственной частью справочника является Навигатор экранных таблиц, представляющий специальную панель инструментов. Подробнее смотрите Работа с экранными таблицами, Контекстное меню экранных таблиц, Навигатор экранных таблиц.

Дополнительно смотрите Справочники системы и меню Справочники главного меню.


Ôîðìû ñèñòåìû è ìåíþ Ôîðìû ãëàâíîãî ìåíþ

Формы системы и меню Формы главного меню

Формы в системе Universal Accounting являются наиболее специализированными объектами. Служат для ввода специализированной справочной информации, некоторых настроек и выполнения определенных действий с данными.

Основное отличие форм от обычных аналитических или системных справочников – это то, что в формах вводимая справочная информация обычно имеет привязку к датам (хранятся значения параметра для каждой даты или периода), т.е. ведется полная история информации, в то время как справочники содержат условно-постоянную информацию (хотя и могут меняться со временем).

Меню Формы Главного меню, в отличие от остальных меню, не имеет четкой структуры. Все пункты в нем (т.е. собственно необходимые формы) определяются администратором системы. Некоторые пункты могут иметь подменю и обозначать не конечную форму, а область применения, к которой относятся все формы, указанные в пунктах подменю.

Пример меню Формы:

Наиболее типичными примерами форм могут служить:

- Регистр курсов валют – задает типы курсов, типы валют и собственно курсы валют по датам. Подробнее смотрите Пример формы – Регистр курсов валют.

- Календарь – задает варианты работы персонала (5*8 и пр.) и для каждого из них определяет количество рабочих, выходных, праздничных дней в каждом месяце. Используется в различных операциях и документах расчета заработной платы. На основе календаря может быть автоматически сформирован прообраз табеля рабочего времени.

- Регистр работников – содержит полную кадровую и расчетную информацию по каждому работнику справочника сотрудников.

- Параметры исчисления подоходного налога – задает параметры расчета подоходного налога, в соответствии с законодательством, для каждого года отдельно.

- Schimbarea codurilor din clasificator – запускает процедуру глобальной замены кодов аналитики по всей базе данных.

Данные пункты меню Формы (или его подменю) используются практически во всех конфигурациях. Однако вполне возможно, что в каждом конкретном случае (особенно в случае использования системы Universal Accounting не в бухгалтерской сфере) даже эти пункты меню Формы могут отсутствовать.

Примеры форм:


Ïðèìåð ôîðìû – Ðåãèñòð êóðñîâ âàëþò

Пример формы – Регистр курсов валют

Форма Регистра курсов валют используется наиболее массово, практически во всех конфигурациях и на всех предприятиях. Доступна при выборе соответствующего пункта меню Формы.

Представляет собой дочернее окно, состоящее из 3-х частей (могут динамически менять размер). Регистр курсов валют предназначен для хранения списка валют и истории их курсов, и используется для счетов, по которым ведется учет в валюте. Все предыдущие значения курса сохраняются вместе с датами их изменения и могут быть просмотрены или изменены.

Описание подокон:

- Подокно типов – позволяет задавать несколько вариантов типов курсов валют: например, курс НБМ и курс какого-нибудь банка.

- Подокно валют – задаются названия валют (полные и краткие, а также их коды).

- Подокно курсов – для выбранного типа курса позволяют задавать и показывают курс выбранной валюты для каждой заданной даты (история курсов).

Исходя из наличия курсов валют, в системе Universal Accounting реализована возможность ведения учета в иностранной валюте. Это может быть удобно и необходимо при расчетах с иностранными покупателями и поставщиками, для кредитов банков, выданных в иностранной валюте и т.д. Информация о ведении валютного учета по тому или иному счету доступна пользователям в Плане счетов. Подробнее смотрите Справочник бухгалтерских счетов. Учет операций в иностранной валюте в основном плане счетов в соответствии с НСБУ ведется на отдельных счетах расчетов и обязательств 2-го уровня (4 цифры).

Таблицы всех 3 подокон представляют собой стандартизированные в рамках системы объекты – экранные таблицы, в соответствии с этим для работы с записями таблиц подокон применяются стандартные горячие клавиши и контекстное меню. Также доступен для использования на активной таблице подокна Навигатор экранных таблиц, расположенный на Основной панели инструментов. Дополнительно смотрите Работа с экранными таблицами, Контекстное меню экранных таблиц, Навигатор экранных таблиц.

Также дополнительно смотрите Формы системы и меню Формы главного меню.


Îò÷åòû ñèñòåìû è ìåíþ Îò÷åòû ãëàâíîãî ìåíþ

Отчеты системы и меню Отчеты главного меню

Для получения бухгалтерских итогов, а также любой другой сводной детальной информации аналитического характера в системе Universal Accounting используются отчеты (выходные формы).

Благодаря общей концепции организации данных (привязка всех уровней аналитики к проводкам), система позволяет свести вычисление большего количества выходной информации для отчетных форм (и не только) к вычислению сальдо и оборотов по соответствующим наборам счетов (синтетическим и аналитическим). Система обеспечивает единый, быстрый и надежный механизм выборки данных о сальдо и оборотах по счетам и, соответственно, возможность получения большого набора отчетных форм в единой концепции.

Количество и состав отчетов, которые могут быть получены при использовании системы, определяются конфигурацией.

Все отчеты можно поделить на две глобальные категории:

- Основанные на данных из бухгалтерских регистров (сальдо, обороты).

- Основанные на дополнительной информации, включая данные из дополнительных (небухгалтерских) регистров.

Отчеты применяются для получения различной информации, которая содержит итоги или детальные данные, подобранные по определенным критериям. Отчеты используются как для анализа бухгалтерских итогов и движения средств (оборотно-сальдовая ведомость, журнал-ордер и пр.), так и для формирования данных для налоговых инспекций и других инстанций (баланс, налоговая отчетность и пр.).

По функциональному назначению можно выделить несколько типов отчетов:

- Универсальные отчеты – предназначены для использования практически в любых организациях и для любых разделов учета. Построены по типу оборотно-сальдовых ведомостей и их вариаций. В основном, они отражают бухгалтерские итоги в различных разрезах для любых указываемых счетов, видов субконто, валют. К универсальным относятся такие отчеты как «Оборотно-сальдовая ведомость», «Шахматка», «Анализ счета», «Карточка счета» и другие. Такие отчеты используются очень широко непосредственно при ведении бухгалтерского учета для анализа бухгалтерских итогов на уровне счетов, субсчетов, валют, объектов аналитики, различных периодов и детальных проводок.

- Финансовые отчеты – предназначены для передачи различным контролирующим инстанциям (бухгалтерский баланс, отчет о финансовых результатах, отчет о движении денежных средств, регистр учета покупок и продаж и др.). Состав и содержание этих отчетов определяется различными государственными органами.

- Специализированные отчеты – создаются обычно в конкретной конфигурации непосредственно для данной организации и решают более узкие задачи. Специализированные отчеты (оборот за период по складу, ведомость основных средств, износ основных средств, карточка клиента, ведомость к выдаче и др.) обычно ориентированы на конкретный раздел учета и специфическую настройку счетов и аналитики в данной конфигурации. Они создаются при необходимости получить специфические выборки информации или особый вид печатной формы.

Интерфейсно, отчеты состоят из следующих частей:

- Менеджер отчетов – специальное дочернее окно системы, в котором осуществляется общее управление и организация отчетной подсистемы Universal Accounting. Подробнее смотрите Менеджер отчетов.

- Экранная форма отчета – предназначена для ввода исходных параметров (условий) отчета (требуемый период, виды аналитики и пр.). Находится на дочернем окне Менеджера отчетов. Подробнее смотрите Экранные формы отчетов – общее описание.

- Печатная форма отчета – собственно сам отчет, сформированный системой на основании информации, хранящиеся в базе данных, и условий, введенных пользователем в экранной форме отчета. Подробнее смотрите Печатные формы отчетов – общее описание.

Доступ к отчетам (к дочернему окну Менеджера отчетов) возможен через меню Отчеты главного меню или горячую клавишу Ctrl+R:

При активном окне Менеджера отчетов меню Отчеты меняет вид, подробнее смотрите Использование схем отчетов.


Ìåíåäæåð îò÷åòîâ

Менеджер отчетов

Менеджер отчетов – специальное дочернее окно системы, в котором осуществляется общее управление и организация отчетной подсистемы Universal Accounting. Доступ к менеджеру отчетов возможен через меню Отчеты главного меню или горячую клавишу Ctrl+R.

Общий вид Менеджера отчетов:

Менеджер отчетов имеет единый принцип построения интерфейса, что обеспечивает однотипную работу пользователей, вне зависимости от конкретной формы отчета. Такими общими управляющими элементами являются:

- Дерево отчетов – представляет пользователю список всех отчетов в древовидном представлении. Обычно узлы дерева соответствуют участкам хозяйственной деятельности и бухгалтерского учета. Доступ к некоторым узлам (их и содержимому) может быть запрещен исходя из прав пользователей. Расположено в левой части диалогового окна Менеджера отчетов.

- [image] Заголовок отчета – название текущего отчета, выбранного в дереве отчетов.

- Элементы для задания периода выборки – поля, предназначенные для задания начальной и конечной даты отчета, с опцией запоминания периода. Подробнее смотрите Задание периода выборки.

- Экранная форма отчета – все пространство между элементами для задания периода выборки и элементами для управления схемами. Экранная форма отчета предназначена для ввода исходных параметров (условий) отчета (виды аналитики и пр.). Внешний вид, количество элементов и процедуры работы отличны для каждого конкретного отчета. Подробнее смотрите Экранные формы отчетов – общее описание.

- Элементы управления схемами отчетов – предоставляют возможность сохранить все заданные условия на экранной форме отчета в виде т.н. Схемы. Подробнее смотрите Использование схем отчетов.

- [image] Кнопка Построить – основная кнопка, нажатие которой запускает процесс формирования отчета (получения печатной формы), также возможно через горячую клавишу F9 (при активном окне менеджера отчетов), или в меню Отчеты (при активном окне менеджера отчетов) – пункт Построить.

Дополнительно смотрите Отчеты системы и меню Отчеты главного меню.


Çàäàíèå ïåðèîäà âûáîðêè

Задание периода выборки

Элементы для задания периода выборки – набор полей, являющихся частью Менеджера Отчетов, предназначенных для задания начальной и конечной даты отчета, с опцией запоминания периода:

По нажатию кнопки [image] появляется контекстное окно расширенного выбора периода:

На этом окне имеются следующие общие элементы:

- Выбор варианта периода – переключатели для каждого из 6 вариантов выбора.

- Наборы изменяемых элементов – определение интервала периода, в зависимости от выбранного варианта периода. Всего имеется, соответственно, 6 различных наборов элементов.

- [image] Кнопка OK – подтверждает сделанный выбор и сворачивает контекстное окно. Используйте Esc для отмены.

Образцы всех наборов изменяемых элементов:

Описание наборов:

- Любой – отсутствуют дополнительные наборы элементов

- День – Признак «С начала месяца», Признак «С начала квартала», Признак «С начала года»

- Месяц – Поле выбора месяца, Поле выбора года, Признак «С начала квартала», Признак «С начала года»

- Квартал – Поле выбора года, Переключатели выбора квартала, Признак «С начала года»

- Полугодие – Поле выбора года, Переключатели выбора полугодия

- Год – Поле выбора года

Дополнительно смотрите Менеджер отчетов.


Èñïîëüçîâàíèå ñõåì îò÷åòîâ

Использование схем отчетов

Схемы отчетов – сохраненные условия экранных форм отчетов (виды аналитики и пр). Благодаря наличию схем отчетов обеспечивается возможность не вводить все условия каждый раз заново, а просто выбирать ранее сохраненный набор условий и параметров экранных форм отчетов.

Использование схем отчетов осуществляется посредством нескольких управляющих элементов, являющихся частью Менеджера отчетов:

Также управление возможно через меню Отчеты Главного меню, которое, при активном Менеджере отчетов, меняет свой вид:

Перечень пунктов меню (и управляющих элементов):

- [image] Сохранить схему (F2) – сохраняет выбранный набор условий и параметров экранной формы отчета в виде схемы (в специальном диалоговом окне вводится название).

- [image] Выбрать схему (F3) – специальное поле с выпадающей таблицей, содержащей перечень всех сохраненных, для данной экранной формы, схем. Сама таблица представляет собой стандартный элемент системы – экранная таблица, управление которой едино в рамках всей системы. Подробнее смотрите Работа с экранными таблицами, Контекстное меню экранных таблиц, Навигатор экранных таблиц.

- [image] Сброс схемы (F6) – сбрасывает все заданные условия и параметры на экранной форме отчета, т.е. очищает (делает пустыми) абсолютно все поля экранной формы отчета.

Теперь параметры отчета каждый раз можно устанавливать путем выбора сохраненной схемы для данного выбранного отчета в дереве отчетов.

Дополнительно смотрите Менеджер отчетов.


Ýêðàííûå ôîðìû îò÷åòîâ - îáùåå îïèñàíèå

Экранные формы отчетов – общее описание

Экранная форма отчета – предназначена для ввода исходных параметров (условий) отчета (виды аналитики и пр.). Находится на дочернем окне Менеджера отчетов.

Для обеспечения общей логики и простоты понимания менеджера отчетов удобно зафиксировать что: Экранная форма отчета – это все пространство, а также расположенные на нем управляющие элементы и объекты между элементами для задания периода выборки и элементами для управления схемами.

Существует 4 типа экранных форм отчетов:

- Универсальный отчет – отчет фиксированного интерфейса, использующий данные бухгалтерских регистров. Элементы экранной формы Универсального отчета предоставляют возможность произвольного конструирования отчета (запроса и печатной формы) по типу оборотно-сальдовой ведомости. Подробнее смотрите Универсальный отчет.

- Настраиваемый отчет – в противоположность универсальному отчету, где интерфейс пользователя фиксирован, но зато настолько развит, что позволяет пользователю конструировать отчет. Экранная форма Настраиваемого отчета полностью определяется администратором системы, из достаточно большого перечня возможных элементов, т.е. Настраиваемый отчет вообще не имеет фиксированной экранной формы. Аналогично и процедуры выборки информации (запросы), а также печатные формы настраиваются администратором системы. Подробнее смотрите Настраиваемый отчет.

- Структурный отчет – Предоставляет пользователю специальные элементы экранной формы, с отображением некоторой структурированной информации. Сами элементы, определяющие структуру, фиксированы, но все содержимое структуры, а также логика выборки информации определяется администратором системы. Подробнее смотрите Структурный отчет.

- Специализированные отчеты – все прочие экранные формы отчетов. Такие формы разрабатываются специально, в зависимости от потребностей того или иного предприятия. Не имеют никаких единых принципов построения и организации, в связи с чем специального рассмотрения экранных форм отчетов данного типа в рамках настоящего Руководства не проводится.

Дополнительно смотрите Отчеты системы и меню Отчеты главного меню.


Óíèâåðñàëüíûé îò÷åò

Универсальный отчет

Универсальный отчет является основным инструментом обработки и получения информации в информационной системе Universal Accounting.

В отличие от Настраиваемого отчета, экранная форма Универсального отчета полностью фиксирована, но в тоже время, предоставляет пользователям возможность произвольного конструирования печатной формы отчета путем выбора и переключения различных параметров и условий. Универсальный отчет генерирует печатные формы в формате FormulaOne (и только). Также жестко фиксирован и сам процесс построения отчета (выборки из базы данных).

Подобная жесткая фиксация всех элементов Универсального отчета (при соблюдении гибкости и возможности настройки) обеспечивает высокую надежность отчетной подсистемы Universal Accounting. Пользователь всегда может быть уверен, что с помощью Универсального отчета он сможет получить корректную и правильную информацию, вне зависимости от конфигурации, изменений администратора системы и прочих факторов.

В качестве основы для извлечения данных Универсальный отчет использует таблицу проводок по документам. Это позволяет обеспечить полноту извлекаемых данных, т.к. именно проводки отражают большую часть информации в системе, исходя из того, что бухгалтерские счета в Universal Accounting являются своеобразным стержнем, к которому привязывается несколько уровней аналитики (подробнее смотрите Справочник бухгалтерских счетов). Даже если некоторая информация и не содержится в таблице проводок, то обычно доступ к ней возможно получить через проводки.

Таким образом, Универсальный отчет является набором правил отображения данных, систематизированных в соответствии со структурой бухгалтерской части базы данных системы, на основе проводок, которые в свою очередь, генерируются и жестко привязаны к первичным документам системы. Структурно проводка содержит:

- Счет и корреспондирующий счет (возможно с субсчетами) – базовые поля, по которым ведется синтетический учет.

- По 3 уровня основной аналитики – аналитика, центр затрат и субконто для счета и корреспондирующего счета. Эти поля обеспечивают возможность ведения аналитического учета для каждого из синтетических счетов.

- По 4 поля дополнительной аналитики – дополнительные поля разных типов, для счета и корреспондирующего счета, обеспечивающие хранение в проводках дополнительной информации (номера партий, дополнительные даты, номера связанных документов и пр.).

- Несколько количественных и суммовых показателей – по счету и корреспондирующему счету количества, цены и суммы разных видов, используемые по необходимости.

Для подробного рассмотрения проводок по документам и структуры синтетических и аналитических счетов (уровней аналитики) обратитесь к следующим разделам: Справочник бухгалтерских счетов, Проводки по документам.

Внешний вид (по умолчанию) экранной формы Универсального отчета:

Настройка Универсального отчета (или конструирование) состоит в процессах:

- Отбор, установка и настройка значений, полей и показателей. Это реализуется через т.н. Стили дизайна.

- Отбор, установка и настройка фильтров по этим значениям, полям и показателям. Это реализуется посредством т.н. Наборов фильтров.

Для удобства работы пользователя форма Универсального отчета является контекстно-изменяемой, т.е. пользователь выбирает определенный набор фильтров и определенный стиль дизайна, и в соответствии с его выбором форма Универсального отчета меняется, показывая графические элементы выбранного набора фильтров и выбранного стиля дизайна. При этом установки, сделанные для каждого из наборов фильтров и стилей дизайна, сохраняются, вместе образуя весь комплекс фильтров, условий, полей, опций и показателей.

Итак, на экранной форме Универсального отчета присутствуют:

- Элементы переключения (выбора) наборов фильтров.

- Элементы переключения (выбора) стилей дизайна.

- Элементы и поля текущего (выбранного) набора фильтров (меняется контекстно).

- Элементы и поля текущего (выбранного) стиля дизайна (меняется контекстно).

В рамках конкретных наборов фильтров и стилей дизайна описаны все доступные для пользователя параметры, условия и показатели, и соответственно, дальнейшее описание Универсального отчета будет состоять из последовательного рассмотрения каждого из набора фильтров и стилей дизайна.

Перечень набора фильтров ( [image] ):

- Основной – основные фильтры по выбранным полям и показателям: счет, субсчет, аналитика, центр затрат, субконто (3 уровня аналитики по счетам). Подробнее смотрите Основной набор фильтров Универсального отчета

- Дополнительный – дополнительные фильтры по выбранным полям и показателям: 4 дополнительных поля разных типов, используемые по необходимости для хранения информации по номерам партий, номерам связанных документов, дополнительным датам и пр. Подробнее смотрите Дополнительный набор фильтров Универсального отчета.

- Документный – фильтры по документам: тип документа, пользователь документа, валюта, а также признак пересчета остатков к выбранным единицам измерения (для конфигураций, где учет ведется одновременно в нескольких единицах измерения). Подробнее смотрите Документный набор фильтров Универсального отчета.

- Настраиваемый – дополнительные 4 фильтра, настраиваемые администратором системы. Их логическое содержание полностью зависит от конкретной конфигурации, поэтому в рамках настоящего Руководства данный набор фильтров подробно рассматриваться не будет.

Перечень стилей дизайна [image] :

- Простой – вид по умолчанию. Предоставляет возможность выбора полей, из списка имеющихся, а также определения по ним требуемых показателей. Подробнее смотрите Простой стиль дизайна Универсального отчета.

- Опции – некоторое количество опций Универсального Отчета. Также в рамках этого стиля дизайна реализуется возможность составления т.н. Сводных таблиц. Подробнее смотрите Опции стиль дизайна Универсального отчета.

- Все – возможность произвольной настройки и выбора всех полей, показателей, опций и пр. Предназначено для администраторов системы, поэтому в рамках настоящего руководства рассмотрено не будет.

В связи со значительным количеством параметров, условий и показателей, в рамках Универсального отчета, целесообразно использовать т.н. Схемы отчетов. Схема отчетов представляет собой сохраненные под определенным именем все установки, поля, условия и показатели по каждому конкретному отчету. Таким образом, пользователь может настроить Универсальный отчет, сохранить его в виде схемы и в дальнейшем не настраивать его заново, а просто выбирать из списка сохраненных схем. Подробнее смотрите Использование схем отчетов.

Также надо иметь в виду, что помимо схем отчетов, некоторые другие элементы (период выборки, кнопка выполнения) являются общими для всех отчетов системы Universal Accounting. Подробнее смотрите Менеджер отчетов, Задание периода выборки.

Дополнительно смотрите Экранные формы отчетов – общее описание.


Îñíîâíîé íàáîð ôèëüòðîâ Óíèâåðñàëüíîãî îò÷åòà

Основной набор фильтров Универсального отчета

Основной набор фильтров Универсального отчета предоставляет возможность установки базовых фильтров по выбранным полям и показателям: счет, субсчет, аналитика, центр затрат, субконто (3 уровня аналитики по счетам).

Внешний вид:

Имеется две группы фильтров:

- Основной фильтр

- Корреспондирующий фильтр

Сами же фильтры идентичны, что обеспечивает возможность независимого указания по каждой из групп.

Перечень фильтров:

- Счет – фильтр по счету. Допускает указание счета любого уровня, или даже класса счетов (2 или 21 или 211 или 2111). Также допустимо перечисление через пробел (2111 2113). Помимо этого можно применять восклицательный знак, обозначающий отрицание (21 !2111).

- .ск – субсчет для указанного счета.

- Аналит. счет – поле для указания аналитики 1-го уровня, исходя из указанного счета. Возможен выбор из справочника (в т.ч. множественный). Подробнее смотрите Множественный выбор из справочников.

- Ц-р затрат – поле для указания аналитики 2-го уровня, исходя из указанного счета. Возможен выбор из справочника (в т.ч. множественный). Подробнее смотрите Множественный выбор из справочников.

- Субконто – поле для указания аналитики 3-го уровня, исходя из указанного счета. Возможен выбор из справочника (в т.ч. множественный). Подробнее смотрите Множественный выбор из справочников.

Дополнительно смотрите Универсальный отчет.


Äîïîëíèòåëüíûé íàáîð ôèëüòðîâ Óíèâåðñàëüíîãî îò÷åòà

Дополнительный набор фильтров Универсального отчета

Дополнительный набор фильтров Универсального отчета предоставляет возможность установки дополнительных фильтров (помимо основных фильтров) по выбранным полям и показателям. Имеются в виду дополнительные поля разных типов, используемые по необходимости для хранения информации по номерам партий, номерам связанных документов, дополнительным датам и пр.

Внешний вид:

Имеется две группы фильтров:

- Основной фильтр

- Корреспондирующий фильтр

Сами же фильтры идентичны, что обеспечивает возможность независимого указания по каждой из групп.

Перечень полей:

- Док. № – поле, для указания фильтра по дополнительному цифровому полю, в таблице проводок. Обычно в это поле заносится номер связанного документа (например, номер ТТН для Акта по ТТН).

- Доп. № – поле, для указания фильтра по дополнительному текстовому полю, в таблице проводок. Обычно в это поле заносится некоторая дополнительная идентификационная информация (например, номера пакетов при начислении дохода по Internet-услугам).

- Дата – список дат для указания фильтра по дополнительному полю типа «дата». Обычно в это поле заносится дополнительная дата (например, для документов по з/п дата – за какой месяц происходит начисление). Обеспечивается указание перечня дат. Для этого выбранные даты заносятся в специальный список. Описание управляющих кнопок: – добавить позицию в список; [image] – удалить позицию из списка; [image] – полностью очистить список.

- Партия – список номеров для указания фильтра по дополнительному цифровому полю. Обычно в это поле заносится дополнительный идентификационный номер (например, номера партий). Обеспечивается указание перечня номеров. Для этого указанные номера заносятся в специальный список. Описание управляющих кнопок: – добавить позицию в список; [image] – удалить позицию из списка; [image] – полностью очистить список.

Дополнительно смотрите Универсальный отчет.


Äîêóìåíòíûé íàáîð ôèëüòðîâ Óíèâåðñàëüíîãî îò÷åòà

Документный набор фильтров Универсального отчета

Документный набор фильтров Универсального отчета предоставляет возможность установки фильтров по документам: тип документа, пользователь документа, валюта, а также признак пересчета остатков к выбранным единицам измерения (для конфигураций, где учет ведется одновременно в нескольких единицах измерения).

Внешний вид:

Перечень полей:

- SYSFID – поле для ввода фильтра по электронному коду типа документов. Обеспечивает возможность получения отчетов по определенному типу операций.

- USERID – поле для ввода фильтра по электронному коду пользователя. Обеспечивает возможность получения отчетов по документам, введенным определенным пользователем.

- Валюта – указание валюты документа. Обеспечивает возможность получения отчетов по документам в определенной валюте. Возможен выбор из справочника (в т.ч. множественный). Подробнее смотрите Множественный выбор из справочников.

- Ед. изм. CANT – обеспечивает возможность пересчета количеств из одних единиц измерений в другие, для конфигураций, где количественный учет ведется в нескольких единицах измерения (определены базовые единицы измерения и коэффициенты пересчета для остальных).

Поля на второй части являются вспомогательными и используются для хранения названия группировки, при выборе в основном наборе фильтров определенной группы из определенной группировки. Это необходимо, исходя из того, что системой обеспечивается возможность ведения нескольких группировок для одного перечня аналитики.

Дополнительно смотрите Универсальный отчет.


Ïðîñòîé ñòèëü äèçàéíà Óíèâåðñàëüíîãî îò÷åòà

Простой стиль дизайна Универсального отчета

Простой стиль дизайна Универсального отчета – вид экранной формы Универсального отчета по умолчанию. Предоставляет возможность выбора полей, из списка имеющихся, а также определения по ним требуемых показателей.

Внешний вид:

Состоит из 3-х частей:

- Управление основными полями – поля счета проводки, выбранного в качестве основного. Именно на эти поля накладываются фильтры всех наборов, относящихся к группе Основной фильтр.

- Управление корреспондирующими полями – поля корреспондирующего счета проводки, Именно на эти поля накладываются фильтры всех наборов, относящихся к группе Корреспондирующий фильтр.

- Управление показателями – поля, позволяющие выбрать показатели: остатки, обороты, количества, суммы, цены и пр. Расположены между элементами управления основными полями и элементами управления корреспондирующими полями.

Управление основными полями и корреспондирующими осуществляется одинаковыми элементами, специального отдельного рассмотрения не требуется. Имеется:

- Управляющая панель инструментов – средства для управления перечнями доступных и выбранных полей (добавление, удаление и пр.).

- Список выбранных полей – перечень полей, добавленных из списка доступных. Рядом с каждым полем имеется возможность установки «галочки» [image] ћ [image] . Таким образом обозначаются поля, по которым необходимо вычислить промежуточные итоги.

- Список доступных полей, для добавления в отчет – скрыт по умолчанию, появляется при нажатии правой кнопкой мыши на списке выбранных полей или через иконку панели инструментов [image] . При повторном нажатии правой кнопки мыши скрывается (а также при активации других элементов управления). В основном содержит перечень полей, присутствующих в таблице проводок (счет, субсчет, 3 уровня аналитики и пр.) или ссылочных полей (например, дата ввода в эксплуатацию ОС не содержится в проводке по ОС, но может быть выведена, т.к. в проводке содержится код ОС). Список дополнительных доступных полей настраивается администратором системы, в зависимости от потребностей предприятия и конкретного учетного участка. Именно в связи с этим, в дереве отчетов могут быть несколько Универсальных отчетов, каждый из которых содержит свой перечень полей (перечень полей для данного участка).

Состав элементов управляющей панели инструментов:

- [image] или [image] Открыть/Закрыть список доступных полей – открывает или закрывает список доступных полей. Также это возможно путем нажатия правой кнопки мыши на списке добавленных полей.

- [image] Добавить поле – добавляет выбранное поле из списка доступных полей в список выбранных полей. Также это доступно путем двойного щелчка левой кнопкой мыши.

- [image] Удалить поле – удаляет активное поле из списка выбранных полей. Также это доступно путем двойного щелчка мыши.

- [image] Переместить вверх – перемещает активное поле из списка выбранных полей на одну позицию вверх, относительно других полей из этого списка.

- [image] Переместить вниз – перемещает активное поле из списка выбранных полей на одну позицию вниз, относительно других полей из этого списка.

- [image] Очистить – полностью очищает (удаляя все поля) список выбранных полей.

Управление показателями осуществляется через определенное количество полей-галочек, включающих и выключающих использование того или иного показателя:

- Нач. остаток, Дт – в отчет будут выведены начальные остатки по дебету.

- Нач. остаток, Кт – в отчет будут выведены начальные остатки по кредиту.

- Оборот, Дт – в отчет будут выведены обороты по дебету.

- Оборот, Кт – в отчет будут выведены обороты по кредиту.

- Кон. остаток, Дт – в отчет будут выведены конечные остатки по дебету.

- Кон. остаток, Кт – в отчет будут выведены конечные остатки по кредиту.

- Показатели, Сумма (лей) – будут рассчитаны и показаны общие суммы, для выбранных начальных остатков, оборотов, конечных остатков.

- Показатели, Количество – будут рассчитаны и показаны количества, для выбранных начальных остатков, оборотов, конечных остатков. Имеет смысл, только в случае вывода в отчет (выбора из списка доступных полей) аналитики, по которой ведется количественный учет.

- Показатели, Цена – в отчет будет выведена цена, для выбранных начальных остатков, оборотов, конечных остатков. Имеет смысл только в случае вывода в отчет (выбора из списка доступных полей) аналитики, по которой ведется количественный учет.

- Показатели, Сумма вал. – в отчет будут выведены суммы в валюте. Имеет смысл только для счетов, по которым ведется валютный учет.

- Показатели, Доп. кол-во – в отчет будет выведено дополнительное количество. Иногда используется в некоторых конфигурациях.

- Показатели, Доп. с-ма – в отчет будет выведено дополнительная сумма.

- Показатели, Курс – в отчет будет выведен валютный курс. Имеет смысл только для счетов, по которым ведется валютный учет.

Также имеется Старое представление Простого стиля дизайна Универсального отчета:

Данное представление имеет аналогичную структуру и возможности. Основное отличие – список полей доступных для добавления и для основных полей и для корреспондирующих полей всегда присутствует на экране, а элементы управления показателями расположены не между основными полями и корреспондирующими, а внизу. В системе доступны сразу оба представления (старое и новое), а переключение представлений осуществляется администратором системы.

Дополнительно смотрите Универсальный отчет.


Îïöèè ñòèëü äèçàéíà Óíèâåðñàëüíîãî îò÷åòà

Опции стиль дизайна Универсального отчета

Опции – некоторое количество опций Универсального отчета. Также в рамках этого стиля дизайна реализуется возможность составления т.н. Сводных таблиц.

Состоит из двух закладок:

- Опции отчета – предоставляет возможность дополнительной настройки Универсального отчета, путем включения или отключения разнообразных опций.

- Сводная таблица – предоставляет возможность составления сводных таблиц (Pivot Tables).

Опции отчета предоставляют возможность дополнительной настройки Универсального отчета, путем включения или отключения разнообразных опций:

Перечень полей:

- Только с обор. – признак, при установке которого в отчет выводятся только позиции, по которым есть обороты по дебету или кредиту.

- Красное сальдо – признак, при установке которого в отчет выводятся только позиции, по которым сальдо на начало или сальдо на конец отрицательно (красное).

- Зарегистр. остатки – признак, при установке которого, при расчете остатков, будут приниматься во внимание не вычисленные остатки с самого начала деятельности, а зафиксированные на определенную дату. Механизм фиксации остатков доступен администратору системы.

- Раскрыть остатки – показатель, при выборе которого в отчет дополнительно выводится вся история остатка (построчно). При этом неважно, в каком периоде образовался остаток (вне заданного интервала отчета).

- Сум. вал. без ЛЕЙ – признак, определяющий, что, когда проводка, использующая показатель сумма в валюте, содержит леи в качестве валюты, то именно для показателя сумма в валюте, такие суммы не показывать. Это очень удобно при совместном выводе сумм в леях и сумм в валюте: при таком дизайне отчетов и при установке данного признака, колонка суммы в леях будет содержать только суммы в леях, а колонка суммы в валюте – только суммы в иностранных валютах.

- Доп. с-ма д/курса – Признак, определяющий, что при расчете курса будет браться дополнительная сумма (сумма GAAP), а не сумма в валюте.

- Все остатки рядом – признак, определяющий группировку показателей. Например, при выборе Суммы и Суммы в валюте и при выборе Остатков на начало, Оборотов, Остатков на конец, возможны 2 варианта расположения показателей: 1-ый – сначала располагаются все показатели для Суммы, а потом все показатели для Суммы в валюте; 2-ой – сначала расположены все остатки на начало (сумма и сумма в валюте), затем обороты (сумма и сумма в валюте), затем остатки на конец (сумма и сумма в валюте).

- Расшифр. слева – признак, при установке которого корреспондирующие поля располагаются перед областью показателей, сразу после основных полей. По умолчанию, корреспондирующие поля располагаются справа, после области показателей.

- Фикс. порядок – признак, при установке которого любое изменение порядка расположения показателей (количество, цена, сумма) будет изменено на стандартное. Настройка нестандартного порядка расположения показателей возможна через стиль дизайна «Все» (доступно администратору системы).

- Пок. пустые обор. – признак, определяющий, что при построении отчета будут выведены даже те позиции аналитики, обороты по которым суммарно нулевые (дебет и кредит совпадают). По умолчанию такие позиции не показываются (даже при присутствии в справочнике).

- Полная детализ. – признак, при установке которого выводится максимальная степень детализации – по проводкам. Обычно, если даже, в корреспонденции выбран документ, то все проводки по одной аналитике, в рамках данного документа, складываются и показываются одной строкой. Установка данного признака позволяет увидеть каждую проводку в отдельности.

Закладка Сводная таблица предоставляет возможность составления сводных таблиц (Pivot Tables). Общая концепция и принципы построения сводных таблиц в системе Universal Accounting аналогичны сводным таблицам в Microsoft Excel. В отличие от Excel, где пользователь определяет и поля для построения по горизонтали и поля по вертикали, а также и область данных, здесь определяются только поля по горизонтали, а остальные поля по вертикали и область данных формируется автоматически (исходя из полей и параметров, определенных в Простом стиле дизайна). Внешний вид закладки:

Перечень элементов:

- Make pivot table – опция, при установке которой, все остальные поля данной вкладки становятся доступными, т.е. у пользователя появляется возможность создавать сводные таблицы.

- Make pivot totals – опция, при установке которой производится автоматический подсчет итогов по полям сводной таблицы.

- Show empty pivots – опция, при установке которой, по аналитике, выбранной в качестве основы для построения сводной таблицы, будет показаны пустые позиции (т.е. будут показаны в т.ч. и те столбцы, для которых область данных пуста). По умолчанию пустые столбцы скрываются.

- Sums inside of pivot – признак, определяющий группировку значений по горизонтали сводной таблицы и параметров. При его установке и при выборе, например, оборотов по дебету и по кредиту, для каждого из значений сводной таблицы (по горизонтали) будут выведены два показателя рядом: обороты по дебету и обороты по кредиту. В противном случае (по умолчанию), в рамках оборотов по дебету, будут выведены все значения сводной таблицы (по горизонтали), а потом еще раз они будут повторены для оборотов по кредиту.

- Virtual merge cells – признак, при котором объединение значений сводной таблицы (из которых образовались новые столбцы) происходит виртуально. Визуально это выглядит почти аналогично стандартному объединению, но реального объединения столбцов не происходит – между ними удаляются разделительные линии, и содержимое всех ячеек, кроме центральной в группе, очищается.

- Expand saldo – признак, определяющий надо ли разлагать по значениям сводной таблицы по горизонтали, остатки на начало и конец, аналогично тому, как (по умолчанию) разложись обороты по дебету и кредиту.

- Pivot fields – Содержит перечень полей сводной таблицы, по которым будет выполнено разложение по горизонтали. Удаление полей осуществляется двойным щелчком мыши.

- Avalable fields – Содержит перечень полей, доступных для разложения по горизонтали. Определяется Основным набором полей форме Простого стиля дизайна. Добавление осуществляется двойным щелчком мыши.

Дополнительно смотрите Универсальный отчет.


Íàñòðàèâàåìûé îò÷åò

Настраиваемый отчет

Настраиваемый отчет – произвольный тип отчетов, не имеющий фиксированной экранной формы для ввода условий и параметров. Допускает как стандартные запросы (обращения к бухгалтерским регистрам), так и специальные запросы (обращения к специальным, небухгалтерским регистрам). Также произвольны и печатные формы настраиваемого отчета (FormulaOne, FastReport, Excel, Word, Ascii Text).

Все эти 3 элемента (экранная форма, запрос и печатная форма) для настраиваемых отчетов полностью настраиваются администратором системы.

Для экранной формы допускается применение достаточно значительного набора элементов (или даже их полное отсутствие) для задания условий и параметров отчета.

Настраиваемый отчет является, таким образом, полной противоположностью Универсального отчета, где интерфейс пользователя фиксирован, но зато настолько развит, что позволяет пользователю самостоятельно конструировать отчет. Благодаря использованию двух, столь разных принципов организации отчетов, система Universal Accounting обеспечивает универсальность, гибкость и приспособляемость к требованиям заказчика.

Примеры экранных форм Настраиваемого отчета:

Надо иметь в виду, что некоторые элементы (период выборки, кнопка выполнения, схемы отчетов) являются общими для всех отчетов системы Universal Accounting. Подробнее смотрите Менеджер отчетов, Задание периода выборки, Использование схем отчетов.

Дополнительно смотрите Экранные формы отчетов – общее описание.


Ñòðóêòóðíûé îò÷åò

Структурный отчет

Структурный отчет предоставляет пользователю специальные элементы экранной формы, с отображением некоторой структурированной информации. Сами элементы, определяющие структуру, фиксированы, но все содержимое структуры определяется администратором системы. Таким образом, у пользователя появляется возможность выбора полей для вывода на печатной форме. Также данная экранная форма предоставляет возможность накладывать условия (в т.ч. множественные) по каждому из полей (выбранных и не выбранных).

Наиболее типичный пример использования данной экранной формы – кадровые отчеты. Действительно, существует огромное количество разнообразной информации по персоналу на предприятии. В разных случаях требуется различные выборки, причем с наложением различных условий (например, все моложе 30 или все женщины, имеющие детей или все военнообязанные и пр.). Структурный отчет как раз и позволяет охватить любые варианты, требуемые пользователями.

В системе это реализовано следующим образом: Имеется список полей, доступных для вывода в отчет. Также имеется список выбранных полей, куда попадают поля, выбранные из 1-го списка пользователем. Дополнительно к этому, имеется элемент для задания условия (в т.ч. множественных условий) по любому из доступных полей (даже если это поле не выбрано пользователем). Возможности задания условий достаточно широкие и зависят от типа поля (для числовых полей можно писать любые арифметические выражения и т.д.). Также имеется поле, где перечислены все, уже заданные условия.

Подробный перечень элементов Структурного отчета:

- Список доступных полей – структурированный перечень полей, доступных для вывода в отчет. Организованы в группы, подгруппы. Для выбора поставить «галочку» возле интересующего поля. «Галочка» на группе полей выбирает все поля этой группы. Удалить из выбора – снять «галочку». Также эти операции доступны через инструменты структурного отчета (см. ниже).

- Список выбранных полей – простой перечень выбранных полей. После простановки «галочки» на поле в Списке доступных полей, поле попадает в данный список. Для удаления возможно снять «галочку» в Списке доступных полей или соответствующим инструментом структурного отчета (см. ниже).

- [image] Добавить – инструмент структурного отчета, добавляет активное поле Списка доступных полей в Список выбранных полей (или можно поставить «галочку» в списке доступных полей).

- [image] Убрать – инструмент структурного отчета, удаляет активное поле Списка выбранных полей (или можно снять «галочку» в Списке доступных полей).

- [image] Вверх – инструмент структурного отчета, перемещает активное поле Списка выбранных полей на позицию вверх.

- [image] Вниз – инструмент структурного отчета, перемещает активное поле Списка выбранных полей на позицию вниз.

- [image] Очисть все – полностью очищает (удаляет) Список выбранных полей.

- [image] Расширенное управление – Позволяет осуществлять добавление, удаление, операции позиционирования через специальное диалоговое окно. Используется в целях администрирования системы, поэтому более подробно в настоящем Руководстве рассмотрено не будет.

- [image] Множественный выбор (только для полей со связанным справочником) – специальное контекстное окно элемента задания условия (слева от него), позволяющее осуществлять множественный выбор из аналитических и системных справочников. Подробнее смотрите Множественный выбор из справочников.

- Условие – элемент, через который задаются условия фильтра. Условие задается для активного поля в Списке доступных полей (даже если это поле не выбрано). Имеет два представления: произвольное условие – позволяет задавать ограничения числовых и текстовых полей путем написания произвольных арифметических и SQL выражений; условие по полю со списком (справочником) – позволяет выбирать одно из имеющихся значений из соответствующего аналитического или системного справочника.

- Список условий – список, где перечислены все заданные на текущий момент условия.

Надо иметь в виду, что некоторые элементы (период выборки, кнопка выполнения, схемы отчетов) являются общими для всех отчетов системы Universal Accounting. Подробнее смотрите Менеджер отчетов, Задание периода выборки, Использование схем отчетов.

Дополнительно смотрите Экранные формы отчетов – общее описание.


Ìíîæåñòâåííûé âûáîð èç ñïðàâî÷íèêîâ

Множественный выбор из справочников

При получении отчетов достаточно часто нужно получить информацию по нескольким элементам одного справочника (например, по 5-ти определенным материалам или 6-ти работникам). Однако стандартный элемент системы Universal Accounting и Windows – поле со списком (справочником) – допускает выбор только одного элемента списка (справочника).

Для решения этой проблемы в системе используется специальное контекстное окно множественного выбора из справочников. Открывается аналогично контекстному списку или справочнику. Инструмент для вызова данного окна располагается справа от поля с выпадающим списком [image] , в противоположность контекстно открываемому окну самого справочника, соответствующая иконка для которого располагается слева от поля с выпадающим списком.

Данная возможность используется, в основном, в рамках Универсального отчета и Структурного Отчета. Подробнее смотрите Универсальный отчет, Настраиваемый отчет, Структурный отчет.

Общий вид поля с выпадающим списком и инструментом для вызова контекстного окна множественного выбора:

Общий вид контекстного окна множественного выбора из справочников:

Перечень инструментов:

- [image] Отрицание – позволяет задавать условия типа «все, кроме …». Обозначается символом «!» (восклицательный знак).

- [image] Добавить – открывает контекстное окно выбора из справочника и, после выбора, добавляет выбранный элемент в списке окна множественного выбора.

- [image] Изменить – открывает контекстное окно выбора из справочника для изменения текущего элемента в списке окна множественного выбора.

- [image] Удалить – удаляет текущий элемент в списке окна множественного выбора.

- [image] Удалить все – полностью очищает (удаляет все выбранные элементы) из списка окна множественного выбора.

- [image] Сохранить – сохраняет заданные условия и закрывает контекстное окно множественного выбора.

- [image] Закрыть – Закрывает без сохранения заданных условий контекстное окно множественного выбора, все выбранные элементы не сохраняются.

Дополнительно смотрите Экранные формы отчетов – общее описание.


Ïå÷àòíûå ôîðìû îò÷åòîâ – îáùåå îïèñàíèå

Печатные формы отчетов – общее описание

Печатные формы отчетов (собственно отчеты или просто печатные формы) представляют собой результат выборки и обработки информации (запроса) из базы данных, условия для которого заданы посредством экранных форм отчетов (разных типов) и экранных форм документов.

Исходя из их программной поддержки, в системе существует несколько типов печатных форм:

- FormulaOne – наиболее развитый тип печатных форм, допускающий пользовательские возможности форматирования текста, ввод формул, группировок, расшифровок, примечаний, а также переход (экспорт) в печатные формы Excel и AsciiText. Используется в большинстве отчетов и для большинства документов (их печатных форм). Подробнее смотрите Отчеты FormulaOne.

- FastReport – печатные формы, используемые в основном в отдельных специализированных отчетах или печатных формах. Сразу открывают состояние предпросмотра перед печатью, соответственно не допускают расширенного форматирования и других возможностей, свойственных печатным формам FormulaOne. Подробнее смотрите Отчеты FastReport.

- AsciiText – печатные формы, для представления информации в которых не используется графические возможности Windows (графические шрифты, графика), а только Ascii-символы, включая псевдографику. Возможен переход в данный тип из FormulaOne печатной формы. Однако, в случае необходимости, отчеты могут быть настроены на прямое получение AsciiText печатной формы. Используется для обеспечения возможности скоростной печати на матричных принтерах. Также, возможен переход (экспорт) из AsciiText к печатной форме Word, с сохранением всего форматирования. Подробнее смотрите Отчеты AsciiText.

- Excel – печатная форма, открываемая в Microsoft Excel. Доступно для любой печатной формы FormulaOne (как экспорт). При экспорте сохраняется все форматирование отчета (графика, формат чисел, шрифты и пр.) и даже формулы! Таким образом, обеспечивается полная совместимость Universal Accounting с Microsoft Excel. Возможна настройка на генерацию выходной печатной формы прямо в Excel (минуя FormulaOne). Подобная прямая генерация Excel отчетов, в основном, используется для специализированных отчетов. Для подробностей по использованию и работе с Excel обратитесь к справочной документации по Microsoft Office.

- Word – печатная форма, открываемая прямо в Microsoft Word. Используется для некоторых документов (например, печатные формы приказов по Отделу Кадров). Для подробностей по использованию и работе с Word обратитесь к справочной документации по Microsoft Office.

Использование полученных в системе печатных форм (собственно отчетов) возможно с помощью специализированных панелей инструментов, некоторые возможности (буфер обмена и пр.) также доступны через специализированные контекстные меню. Для работы с печатными формами (отчетами), сгенерированными прямо в Excel или Word необходимо использовать средства и возможности этих систем. Сама печатная форма (отчет) в системе Universal Accounting представляет собой отдельное дочернее окно системы, что обеспечивает одновременный просмотр и работу с множеством печатных форм (отчетов). Таким образом, для печатных форм и отчетов системы можно выделить несколько общих элементов интерфейса:

- Панель инструментов – бывает разных видов, в зависимости от типа печатных форм (FormulaOne, FastReport, AsciiText).

- Поле отчета – собственно сам отчет (печатная форма) – практически все пространство дочернего окна, где и внесены данные, графика, текст.

- Контекстное меню – показыается при нажатии правой кнопки мыши на поле отчета. Может содержать разные элементы, в зависимости от типа печатных форм (FormulaOne, FastReport, AsciiText).

Дополнительно смотрите Отчеты системы и меню Отчеты главного меню.


Îò÷åòû FormulaOne

Отчеты FormulaOne

Отчеты FormulaOne – наиболее развитый и широко используемый тип печатных форм в системе Universal Accounting. Применяется в большинстве отчетов системы, допускает пользовательские возможности форматирования текста, ввод формул, группировок, расшифровок, примечаний, а также переход (экспорт) в печатные формы Excel и AsciiText.

Печатные формы FormulaOne генерируются из любых видов экранных форм отчетов и документов (Универсальный отчет, Настраиваемый отчет, Структурный отчет), а для Универсального отчета и Структурного отчета являются единственно возможными.

Отчеты FormulaOne представляют собой Excel-подобные таблицы с идеологией, аналогичной электронным таблицам Microsoft Excel. Аналогично существуют т.н. страницы, каждая страница представляет собой таблицу ячеек, каждая ячейка имеет уникальный номер, складываемый из буквенного номера ячейки по горизонтали и числового номера ячейки по вертикали. Также возможно написание формул (с аналогичным синтаксисом), имеется строка формул. Для пользователей Universal Accounting, обычно, все эти подробности скрыты, но могут быть показаны при использовании соответствующих кнопок на панели инструментов отчетов FormulaOne (режим отображения сетки и режим редактирования).

Пример отчета FormulaOne (сгенерированного на основании экранной формы Универсального Отчета):

Панель инструментов содержит следующие инструменты:

- [image] Открыть – предназначено для администраторов системы, позволяет прямо из сгенерированного отчета открывать шаблоны для данного отчета.

- [image] Сохранить – вызывает стандартное диалоговое окно Windows для сохранения отчета в файле формата VTS (формат отчетов FormulaOne).

- [image] Сохранить схему с шаблоном – предназначено для администраторов системы, позволяет прямо из сгенерированного отчета сохранить схему отчета и временный шаблон (возможно предварительно измененный). Далее, сохраненная схема доступна для выбора пользователей в менеджере отчетов. Дополнительно смотрите Использование схем отчетов.

- [image] Параметры страницы – вызывает диалоговое окно настройки параметров печати отчета. Параметры страницы устанавливаются в шаблоне отчета, но могут быть исправлены или дополнены пользователем. Подробнее смотрите Настройка параметров страниц отчетов FormulaOne.

- [image] Параметры печатающего устройства – вызывает стандартное диалоговое окно Windows, позволяющее выбрать принтер из установленных в системе и настроить такие параметры как размер бумаги и ориентацию.

- [image] Печать – выполняет печать отчета из системы. Примечание: В данном режиме выполняется печать только по одному экземпляру. Для одновременной печати множества экземпляров используйте инструмент [image] - Печать через Excel (см. ниже).

- [image] Печать через Excel – вызывает диалоговое окно, позволяющее выполнить печать отчета через Microsoft Excel. Подробнее смотрите Настройка параметров печати через Excel отчетов FormulaOne.

- [image] Показать сетку – Включает / выключает режим показа сетки таблицы отчета.

- [image] Редактирование в ячейках – Включает / выключает режим редактирования. Подробнее смотрите Редактирование отчетов FormulaOne.

- [image] Зафиксировать заголовки – позволяет зафиксировать заголовки отчета – области сверху и слева таблицы отчета, которые не будут скрываться при пролистывании вниз или вправо. Заголовки фиксируются для текущей активной ячейки, т.е. вся область отчета вверх и влево от текущей ячейки будет определена как горизонтальные и вертикальные заголовки.

- [image] Шрифт – предоставляет возможность выбора шрифта из установленных в системе для текущей ячейки (или диапазона ячеек).

- [image] Размер шрифта – предоставляет возможность выбора размера шрифта для текущей ячейки (или диапазона ячеек).

- [image] Кодировка – предоставляет возможность выбора кодировки текста для текущей ячейки (или диапазона ячеек).

- [image] Полужирный – устанавливает полужирный стиль начертания выбранного шрифта для текущей ячейки (или диапазона ячеек).

- [image] Курсив – устанавливает курсивный стиль шрифта для текущей ячейки (или диапазона ячеек).

- [image] Подчеркнутый – устанавливает подчеркнутый стиль для текущей ячейки (или диапазона ячеек).

- [image] Workbook designer – предназначено для администраторов системы. Открывает отчет в FormulaOne Workbook Designer.

- [image] Экспорт в Excel – преобразует (экспортирует) печатную форму FormulaOne в печатную форму Microsoft Excel. Выполняется полный экспорт данных, форматирования, графики, формул. Для подробностей по использованию и работе с Excel обратитесь к справочной документации по Microsoft Office.

- [image] Печать в простой текст – преобразует (экспортирует) печатную форму FormulaOne в печатную форму AsciiText (без использования графических возможностей Windows). Используется для обеспечения скоростной печати на матричных принтерах. Подробнее смотрите Отчеты AsciiText.

- [image] Печать сложных фактур – используется только для отдельных отчетов FormulaOne. В случае необходимости, администратор системы имеет возможность настроить для этой кнопки сложный алгоритм печати (например 1 страница – 2 копии, 3-5 – 5 копий).

- [image] Поиск в тексте – вызывает диалоговое окно поиска текста в отчете. Для режима редактирования также обеспечивает возможность замены. Подробнее смотрите Поиск и замена текста в отчетах FormulaOne.

- [image] Переход к документу или отчету – система Universal Accounting обеспечивает возможность прямого перехода из отчетов к документам системы. При выборе в печатной форме отчета, в качестве текущей ячейки, документа (его номера), возможна его активация путем использования данного инструмента или двойного щелчка мыши или контекстного меню отчетов FormulaOne. Аналогично возможен переход из отчета к другому отчету, с более расширенным уровнем аналитики.

- [image] Обновить отчет – осуществляет перегенерацию отчета, заново извлекая и обрабатывая информацию в базе данных.

- [image] Перейти к панели построения отчета – переход к дочернему окну менеджера отчетов, без закрытия дочернего окна самого отчета (печатной формы).

Также некоторые функции по использованию буфера обмена доступны через контекстное меню отчетов FormulaOne или горячие клавиши. Подробнее смотрите Контекстное меню отчетов FormulaOne.

Дополнительно смотрите Печатные формы отчетов – общее описание.


Íàñòðîéêà ïàðàìåòðîâ ñòðàíèö îò÷åòîâ FormulaOne

Настройка параметров страниц отчетов FormulaOne

Отчеты FormulaOne допускают широкие возможности по настройке параметров разметки и печати отчетов. Для этого используется специальное диалоговое окно Настройки параметров страниц отчетов FormulaOne. Вызывается [image] инструментом на панели инструментов отчетов FormulaOne. Данные параметры устанавливаются (по умолчанию) в шаблоне отчета администратором системы, но могут быть изменены пользователем в процессе работы.

Исходя из общей идеологии FormulaOne, аналогичной Microsoft Excel, настройка параметров страниц в Formula осуществляется аналогичными с Excel способами, используется аналогичное разделение по закладкам и аналогичные элементы.

Диалоговое окно состоит из следующих общих элементов:

- Закладка Page – содержит элементы для настройки параметров печати страниц.

- Закладка Margins – содержит элементы для установки полей (отступов от краев листа).

- Закладка Header/Footer – содержит элементы для настройки верхнего и нижнего колонтитула.

- Закладка Sheet – содержит элементы для настройки параметров отображения печатного отчета.

- Кнопка Ok – сохраняет сделанные изменения.

- Кнопка Cancel – закрывает диалоговое окно настройки параметров печати страниц без сохранения.

Закладка Page содержит элементы для настройки параметров печати страниц:

Перечень элементов:

- Orientation, Portrait – устанавливает книжную ориентацию листов для печати.

- Orientation, Landscape – устанавливает альбомную ориентацию листов для печати.

- Scalling, Adjust to …% normal size – устанавливает масштаб листа при печати, в процентах к нормальному масштабу.

- Scalling, Fit to … page(s) wide by … – подгоняет масштаб листа при печати, к заданному количеству печатных страниц по горизонтали и по вертикали.

- Paper size – определяет размер печатного листа (обычно A4).

- Page Numbering, Automatic – устанавливает автоматический режим присвоения номеров страниц (начиная с 1).

- Page Numbering, Start with page number … – позволяет установить номер начальной страницы, отличный от 1 (единицы).

Закладка Margins содержит элементы для установки полей (отступов от краев листа), в выбранных единицах измерения:

Перечень элементов:

- Top – отступ отчета сверху от края листа

- Bottom – отступ отчета снизу от края листа

- Left – отступ отчета слева от края листа

- Right – отступ отчета справа от края листа

- Header – отступ верхнего колонтитула от верха листа

- Footer – отступ нижнего колонтитула от низа листа

- Center on page, Horizontally – устанавливает режим горизонтальной центровки отчета от краев листа.

- Center on page, Vertically – устанавливает режим вертикальной центровки отчета от краев листа.

- Units – позволяет осуществить выбор используемых единиц измерения расстояний отступов (сантиметры, дюймы).

Закладка Header/Footer содержит элементы для настройки верхнего и нижнего колонтитула отчета (колонтитулы – текст вверху и внизу документа, отображаемый на каждой распечатываемой странице отчета):

Перечень элементов:

- Header – поле, определяющее верхний колонтитул. Допускает использование подстановочных символов (&P – номер страницы, &N – общее число страниц, &D – дата печати, &T – время печати).

- Footer – поле, определяющее нижний колонтитул. Допускает использование таких же подстановочных символов, как и верхний колонтитул.

Закладка Sheet – содержит элементы для настройки параметров отображения печатного отчета.

Перечень элементов:

- Print Area – установка фиксированной области печати. По умолчанию, в область печати включается весь диапазон ячеек, где имеются данные, но пользователь может ограничить ее. При задании области печати необходимо применять стандартный синтаксис Excel. Для подробностей по синтаксису написания диапазонов ячеек обратитесь к справочному руководству по Microsoft Excel.

- Print Titles – установка диапазона ячеек для печати на каждой странице. Используется для задания заголовков таблиц (также используя синтаксис Microsoft Excel).

- Print Options, Grid Lines – показ при печати сетки.

- Print Options, Black and White – печать в черно-белом варианте.

- Print Options, Row Headers – печать заголовков строк.

- Print Options, Row Headers – печать заголовков столбцов.

- Page Order, Top to Bottom – порядок печати отчета сверху вниз.

- Page Order, Top to Bottom – порядок печати отчета слева на право.

Дополнительно смотрите Отчеты FormulaOne.


Íàñòðîéêà ïàðàìåòðîâ ïå÷àòè ÷åðåç Excel îò÷åòîâ FormulaOne

Настройка параметров печати через Excel отчетов FormulaOne

Отчеты FormulaOne позволяют выполнять печать через Microsoft Excel (используя подсистему печати Excel). Для этого используется инструмент [image] на панели инструментов отчетов FormulaOne. Открывается специальное диалоговое окно Настройки параметров печати через Excel, в случае подтверждения которых выполняется печать:

Перечень элементов:

- Выберите принтер – выбор принтера, из списка принтеров, установленных в системе.

- Ориентация, портретная – устанавливает книжную (портретную) ориентацию страницы для печати.

- Ориентация, альбомная – устанавливает альбомную ориентацию страницы для печати.

- Копии – устанавливает количество копий для печати.

- Область печати, все – печать всех ячеек с данными.

- Область печати, выделение – печать выделенных ячеек.

- Область печати, интервал – печать интервала страниц.

- Интервал страниц, от страницы … до страницы … – устанавливает интервал страниц, необходимо для выбранной опции Область Печати: Интервал.

- Опции, разбор копий – устанавливает опцию разбора по копиям для печатных страниц.

- Опции, печать в файл … – устанавливает опцию печати в файл формата PRN. Имеется поле для ввода имени файла.

- Кнопка ОК – осуществляет печать через Excel, исходя из заданных параметров.

- Кнопка Отмена – закрывает окно, отменяя печать.

Дополнительно смотрите Отчеты FormulaOne.


Ðåäàêòèðîâàíèå îò÷åòîâ FormulaOne

Редактирование отчетов FormulaOne

Для отчетов FormulaOne доступен режим редактирования, включаемый при нажатии иконки [image] на панели инструментов отчетов FormulaOne. Также целесообразно, для режима редактирования, включить отображение сетки иконкой [image] .

Исходя из того, что отчеты FormulaOne представляют собой Excel-подобные таблицы с идеологией, аналогичной электронным таблицам Microsoft Excel, фактически, в режиме редактирования печатные формы FormulaOne системы Universal Accounting представляют собой электронную таблицу, с функциями и средствами, аналогичными Microsoft Excel (без необходимости наличия и загрузки самого Excel).

В то же время сохраняется и возможность переноса данных в Excel (экспорта), с полным сохранением форматирования, формул и данных. Для этого используется иконка [image] на панели инструментов отчетов FormulaOne.

Внешний вид дочернего окна отчета FormulaOne в режиме редактирования:

Итак, в режиме редактирования, помимо самой таблицы, дополнительно показываются:

- Строка формул – показывает формулу ячейки, в отличие от пространства таблицы, где показывается результат вычисления формулы.

- Заголовки строк – числовые заголовки строк таблицы.

- Заголовки столбцов – буквенные заголовки столбцов таблицы (комбинации номеров строк и столбцов образует уникальные коды ячеек таблицы, которые можно использовать в формулах).

Для режима редактирования доступно любое изменение, удаление, вставка текста или других символов (в т.ч. используя буфер обмена через контекстное меню или горячие клавиши).

Также возможно написание произвольных формул. Синтаксис формул аналогичен синтаксису Microsoft Excel. В формулах также возможно использование элементарных функций (также аналогично Excel). Для подробностей обратитесь к справочной документации по Microsoft Excel.

Помимо этого, для режима редактирования доступно изменение форматирования ячеек (шрифт, размер шрифта, начертание и пр.), путем использования соответствующих иконок на панели инструментов отчетов FormulaOne.

Еще более расширенное редактирование (линии границ, управление листами, именованные диапазоны и пр.), предназначенное для администраторов системы, доступно через иконку [image] (FormulaOne Workbook Designer) на панели инструментов отчетов FormulaOne.

Дополнительно смотрите Отчеты FormulaOne.


Ïîèñê è çàìåíà òåêñòà â îò÷åòàõ FormulaOne

Поиск и замена текста в отчетах FormulaOne

В отчетах FormulaOne имеются средства поиска и замены текста (замена текста – только для режима редактирования). Реализуется посредством специального диалогового окна, которое вызывается через инструмент [image] , расположенный на панели инструментов отчетов FormulaOne, или по горячей клавише Ctrl+F.

Данные средства полностью аналогичны средствам поиска и замены Microsoft Excel.

Внешний вид окна поиска:

Перечень элементов:

- Find What … – данные, которые требуется найти.

- Search … – порядок поиска (по строкам, по столбцам).

- Look in … – определяет область поиска (формулы, значения).

- Match Case – определяет, надо ли учитывать регистр символов при поиске.

- Find entire Cells Only – поиск ячейки целиком (Поиск полного и точного совпадения со строкой введенной в поле Find What).

- Кнопка Find Next – поиск следующей ячейки, содержащей искомую строку знаков.

- Кнопка Close – закрывает диалоговое окно поиска.

- Кнопка Replace… – переключает окно на режим замены.

Внешний вид окна замены:

Перечень элементов:

- Find What … – данные, которые требуется найти.

- Replace With … – данные, которыми требуется заменить найденные данные.

- Search … – порядок поиска (по строкам, по столбцам).

- Match Case – определяет, надо ли учитывать регистр символов при поиске.

- Find entire Cells Only – поиск ячейки целиком (Поиск полного и точного совпадения со строкой, введенной в поле Find What).

- Кнопка Find Next – поиск следующей ячейки, содержащей искомую строку знаков.

- Кнопка Close – закрывает диалоговое окно поиска.

- Кнопка Replace – заменяет найденные данные в одной ячейке.

- Кнопка Replace All – заменяет найденные данные во всех ячейках.

Дополнительно смотрите Отчеты FormulaOne.


Êîíòåêñòíîå ìåíþ îò÷åòîâ FormulaOne

Контекстное меню отчетов FormulaOne

В печатных формах отчетов FormulaOne допускается использование единого буфера обмена Windows. Таким образом, обеспечивается перенос данных между любыми Windows-приложениями. Эти функции доступны через контекстное меню печатной формы или горячие клавиши:

Для режима редактирования доступны все функции этого меню, для режима просмотра только некоторые из них:

- Cut (Shift+Del, Ctrl+X) – вырезать в буфер обмена Windows выделенное содержимое ячейки (или выделенный диапазон ячеек).

- Copy (Ctrl+Ins, Ctrl+C) – копировать в буфер обмена Windows выделенное содержимое ячейки (или выделенный диапазон ячеек).

- Paste (Shift+Ins, Ctrl+V) – вставить из буфера обмена его содержимое в активную ячейку.

- Delete (Ctrl+Del) – удаление выделенной ячейки или диапазона ячеек.

- Clear (Del) – очистка содержимого ячейки или диапазона ячеек.

- Go to ... – выпадающее подменю, позволяющее осуществить прямой переход от печатной формы к документу или другому отчету, с аналитикой более низкого уровня. Также данная функция доступна путем двойного щелчка мыши на ячейке или с помощью инструмента [image] на панели инструментов отчетов FormulaOne.

Дополнительно смотрите Отчеты FormulaOne.


Îò÷åòû FastReport

Отчеты FastReport

FastReport – печатные формы, используемые в основном в отдельных специализированных отчетах или печатных формах. Сразу открывают состояние предпросмотра перед печатью, соответственно не допускают расширенного пользовательского форматирования и других возможностей, свойственных печатным формам FormulaOne. Часто используются для обеспечения возможности вывода на печатных формах эмблем, фирменных знаков или других рисунков. Возможна генерация печатных форм отчетов FastReport из экранных форм Настраиваемого отчета и экранных форм документов.

Пример отчета FastReport:

Панель инструментов содержит следующие элементы:

- [image] Scale – выбор из выпадающего списка масштаба просмотра на экране печатной формы. Также эти функции доступны через контекстное меню отчетов FastReport.

- [image] Open report (Ctrl+O) – вызывает стандартное диалоговое окно Windows для открытия файла отчета формата FRP (формат отчетов FastReport).

- [image] Save report (Ctrl+S) – вызывает стандартное диалоговое окно Windows для сохранения отчета в файле формата FRP (формат отчетов FastReport).

- [image] Print report (Ctrl+P) – вызывает диалоговое окно настройки параметров печати отчета и после подтверждения осуществляет печать отчета. Подробнее смотрите Настройка параметров печати отчетов FastReport.

- [image] Find text (Ctrl+F) – вызывает диалоговое окно поиска текста в отчетах FastReport. Подробнее смотрите Поиск текста в отчетах FastReport.

- [image] Show help – не используется.

- [image] Close preview – закрывает дочернее окно отчета FastReport.

Дополнительно смотрите Печатные формы отчетов – общее описание.


Íàñòðîéêà ïàðàìåòðîâ ïå÷àòè îò÷åòîâ FastReport

Настройка параметров печати отчетов FastReport

Перед печатью отчета FastReport вызывается диалоговое окно настройки параметров печати. Печать отчетов FastReport осуществляется через инструмент [image] (печать отчета) на панели инструментов печатных форм FastReport. Также возможен вызов по горячей клавише Ctrl+P. Внешний вид окна:

Описание элементов:

- Printer, Name – поле с выпадающим списком, позволяющее выбрать принтер, на который будет осуществлена печать, из списка принтеров, установленных в системе.

- Printer, Кнопка Properties – вызывает диалоговое окно настройки параметров принтера. Вид окна и перечень параметров зависят от типа принтера.

- Page range, All – выбор интервала печати, печать всего отчета.

- Page range, Current Page – выбор интервала печати, печать текущей страницы.

- Page range, Pages – выбор интервала печати, явное указание страниц для печати. Допускает задание сложных интервалов путем использования «,» и «-», вида: «1,3,5-12».

- Copies, Number of copies – позволяет задавать число печатных копий отчета.

- Copies, Collate – устанавливает опцию разбора по копиям для печатных страниц.

- Print (All, Odd, Even) – включить в печать: все страницы, нечетные страницы, четные страницы).

- Кнопка Ok – печать отчета, исходя из установленных параметров на данном диалоговом окне.

- Кнопка Cancel – закрытие диалогового окна, печать не выполняется.

Дополнительно смотрите Отчеты FastReport.


Ïîèñê òåêñòà â îò÷åòàõ FastReport

Поиск текста в отчетах FastReport

В печатных формах отчетов FastReport доступна возможность поиска текста. Осуществляется через специальное диалоговое окно, вызываемое инструментом [image] (искать текст) на панели инструментов отчетов FastReport. Также возможен вызов по горячей клавише Ctrl+F.

Внешний вид окна:

Перечень элементов:

- Text to find – поле для ввода искомого текста.

- Options, Case sensitive – опция учета регистра символов при поиске.

- Origin, 1st page – устанавливает интервал поиска: с 1-ой страницы.

- Origin Current page – устанавливает интервал поиска: с текущей страницы.

Дополнительно смотрите Отчеты FastReport.


Îò÷åòû AsciiText

Отчеты AsciiText

AsciiText – печатные формы, для представления информации в которых не используется графические возможности Windows (графические шрифты, графика), а только Ascii-символы, включая псевдографику.

Используется для обеспечения возможности скоростной печати на матричных принтерах.

Возможно несколько способов получения AsciiText печатной формы:

- Прямое получение отчета данного типа (доступно для экранных форм настраиваемого отчета и экранных форм документов).

- Переход (экспорт) из печатной формы FormulaOne с помощью инструмента [image] (Печать в простой текст) на панели инструментов FormulaOne.

Пример отчета AsciiText:

Панель инструментов содержит следующие элементы:

- [image] Печать – Появляется окно установки параметров печати, после их подтверждения осуществляется печать отчета.

- [image] Выбор шрифта – открывает стандартное, для операционной системы Windows, окно выбора шрифта и его параметров: размер, начертание, цвет и пр. Для подробного описания обратитесь к справочному руководству по Microsoft Windows.

- [image] Параметры печати – открывает контекстное окно задания параметров печати, с возможностью выбора принтера. При подтверждении, сохраняет параметры печати, без осуществления самой печати (в отличие от инструмента Печать). Подробнее смотрите Настройка параметров печати отчетов AsciiText.

- [image] Экспорт в Word – Переход (экспорт) из AsciiText печатной формы системы к печатной форме Word, при этом все содержимое отчета переносится в документ Word с полным сохранением форматирования.

- [image] Сохранить – позволяет сохранить печатную форму (отчет) как текстовый файл (по умолчанию с расширением .txt), для этого вызывается стандартное диалоговое окно Windows. Для подробного описания обратитесь к справочному руководству по Microsoft Windows.

Также некоторые функции по работе с буфером обмена доступны через контекстное меню или горячие клавиши. Подробнее смотрите Контекстное меню отчетов AsciiText.

Дополнительно смотрите Печатные формы отчетов – общее описание.


Íàñòðîéêà ïàðàìåòðîâ ïå÷àòè îò÷åòîâ AsciiText

Настройка параметров печати отчетов AsciiText

Для настройки параметров печати отчетов AsciiText используется специальное диалоговое окно Параметры печати. Данное окно вызывается при нажатии кнопки [image] (параметры печати) на панели инструментов отчетов AsciiText.. Также данное окно вызывается непосредственно перед печатью (инструмент [image] ). Внешний вид окна:

Перечень полей:

- Imprimanta – позволяет выбрать принтер, из имеющихся в системе

- Direct Print – устанавливает опцию прямой печати на выбранный принтер, минуя подсистему печати операционной системы Windows.

- Exemplare – устанавливает количество копий

- Documentul in intregime – Печать всего текста

- Fragment selectat – печать выделенного фрагмента текста

- Intervalul paginelor – печать интервала страниц (с … по …)

- Print to file – устанавливает опцию печати в файл формата PRN. Имеется поле для ввода имени файла.

- Кнопка OK – сохраняет сделанные установки и изменения

- Кнопка Renuntarea – закрывает окно, без сохранения изменений.

Дополнительно смотрите Отчеты AsciiText.


Êîíòåêñòíîå ìåíþ îò÷åòîâ AsciiText

Контекстное меню отчетов AsciiText

 Начало Предыдущий

В печатных формах отчетов AsciiText допускается использование единого буфера обмена Windows. Таким образом, обеспечивается перенос данных между любыми Windows-приложениями. Эти функции доступны через контекстное меню печатных форм или горячие клавиши:

В связи с отсутствием возможностей редактирования в отчетах AsciiText, доступны только некоторые функции:

- Copy (Ctrl+C, Ctrl+Ins) – копировать в буфер обмена Windows выделенные символы (текст, числа и пр.). Для доступности данного пункта меню текст должен быть заранее выделен мышкой.

- Select All (Ctrl+A) – выделение всего содержимого отчета.

Дополнительно смотрите Отчеты AsciiText.